Debian: SSI?

Web page creation, programs, scripts, PHP, SQL?

Moderator: Moderators

Debian: SSI?

Postby hu8_debian » Thu Aug 17, 2006 9:51 pm

Hmm.. I tried to write the following pieces of code in a .htaccess

AddType text/html .shtml
AddHandler server-parsed .shtml

(which makes nothing)

... I tried
Options +Includes
AddType text/html .shtml
AddOutputFilter INCLUDES .html
...which made an Internal Server Error on _every_ page.

So...how do I enable SSIs?
(With no .htaccess it does still not work on debian) :(

thank you in advance for help...
hu8_debian
Newbie
 
Posts: 9
Joined: Tue May 23, 2006 6:18 pm
Location: Wien

Postby miker_alpha » Fri Aug 18, 2006 10:50 am

I don't know exactly how it works on Debian, but IIRC AllowOverride must be enabled for whatever you want to change in an .httaccess file. Can you read the httpd.conf file on the Debian server?

MikeR
Look for OpenVMS help on my webpage
Check for QOTD here.
Image
User avatar
miker_alpha
Moderator
Moderator
 
Posts: 256
Joined: Sat May 08, 2004 9:20 am
Location: Kibbutz Tzora, Israel

Postby sjaz » Fri Aug 18, 2006 11:22 am

No shell access to debian here, but I'd guess its already enabled.
User avatar
sjaz
Forum Admin
Forum Admin
 
Posts: 689
Joined: Fri Feb 14, 2003 11:08 pm
Location: London, UK

Postby hu8_debian » Fri Aug 18, 2006 11:49 am

Code: Select all
hu8@debian:/etc/apache2$ grep ".*AllowOverride.*" < /usr/local/apache2/conf/httpd.conf
    AllowOverride None
# AllowOverride controls what directives may be placed in .htaccess files.
    AllowOverride None
#    AllowOverride FileInfo AuthConfig Limit Indexes
# for additional configuration directives.  See also the AllowOverride
    AllowOverride None
    AllowOverride None
    AllowOverride None
        AllowOverride None

Na....no AllowOverride :(

But:
Code: Select all
915-AddType text/html .shtml
916-AddOutputFilter INCLUDES .shtml

is in the httpd.conf :)


But:
Code: Select all
<html>
 <head>
  <title>Hallo!</title>
 </head>
 <body>
  <!-- #include file="index.html" -->
 </body>
</html>

saved under test.shtml will not include the index.html :(
hu8_debian
Newbie
 
Posts: 9
Joined: Tue May 23, 2006 6:18 pm
Location: Wien

Postby miker_alpha » Sat Aug 19, 2006 1:31 pm

Try looking at /server-info on debian; check:
1. is mod_mime loaded (should be)
2 Whether AddOutputFilter appears as activated -- perhaps theres a syntax flaw in http.conf
3 What happens if you put a path in the include? I.e:
/~myuser/index.html ?

Thats all I could think of right now. Good luck!

MikeR

New OpenVMS page up at http://80.179.10.146/ -- haven't got round to setting up a DNS yet.
Look for OpenVMS help on my webpage
Check for QOTD here.
Image
User avatar
miker_alpha
Moderator
Moderator
 
Posts: 256
Joined: Sat May 08, 2004 9:20 am
Location: Kibbutz Tzora, Israel

Postby hu8_debian » Sat Aug 19, 2006 8:15 pm

http://www.polarhome.com:753/phpinfo/
says mod_mime is installed... but it says nothing about mod_ssi :(

adding a path, doesn't bring anything (made it as an absolute path).
hu8_debian
Newbie
 
Posts: 9
Joined: Tue May 23, 2006 6:18 pm
Location: Wien

Postby miker_alpha » Fri Aug 25, 2006 4:47 pm

don't remember anything rellated to mod_ssi

IIRC " AddHandler server-parsed .shtml " should be enough...
Sorry -- no more ideas. :oops:
MikeR
Look for OpenVMS help on my webpage
Check for QOTD here.
Image
User avatar
miker_alpha
Moderator
Moderator
 
Posts: 256
Joined: Sat May 08, 2004 9:20 am
Location: Kibbutz Tzora, Israel

Postby DenisF » Fri Aug 25, 2006 8:49 pm

hu8_debian wrote:But:
Code: Select all
915-AddType text/html .shtml
916-AddOutputFilter INCLUDES .shtml

is in the httpd.conf :)


Am i the only one to notice that those two lines are commented out?[915/916]
Image
[ FAQ ] :: [ Policy ] :: [ Port Forwarding Guide ] :: [ Search ]
User avatar
DenisF
Forum Admin
Forum Admin
 
Posts: 679
Joined: Mon Dec 16, 2002 9:09 pm
Location: Israhell

Postby hu8_debian » Fri Aug 25, 2006 10:24 pm

...I looked and I didn't see that they're commented out? :twisted:

I looked in /usr/local/apache2/conf/httpd.conf
hu8_debian
Newbie
 
Posts: 9
Joined: Tue May 23, 2006 6:18 pm
Location: Wien

Postby davido » Sun Sep 03, 2006 5:06 pm

Hi,

I have the same problem on Debian...
I get "Internal Server Error" every time if I use DirectoryIndex :(
davido
Newbie
 
Posts: 3
Joined: Fri Jun 02, 2006 2:38 pm

Postby miker_alpha » Sun Sep 03, 2006 7:19 pm

IIRC one of the reasons for "Internal server error" is referencing an unloaded module (been there, done that -- different module though)

MikeR
Look for OpenVMS help on my webpage
Check for QOTD here.
Image
User avatar
miker_alpha
Moderator
Moderator
 
Posts: 256
Joined: Sat May 08, 2004 9:20 am
Location: Kibbutz Tzora, Israel


Return to Web development

Who is online

Users browsing this forum: No registered users and 1 guest

cron