A CGI Scripts Question

Web page creation, programs, scripts, PHP, SQL?

Moderator: Moderators

A CGI Scripts Question

Postby z0_redhat » Fri Mar 09, 2007 10:42 am

Hi everyone,

I have a small question to ask.

Okey I been tryin to install a perl board on my redhat box, but whenever I
try to run the install.cgi script, it seems as if the server doesnt recognize the type of file or extention. I even created a CGI-BIN directory inside the public_html and still wont work. I'm pretty sure the perl path is /usr/bin/perl.

What is it that I'm doing wrong?

I would really appreciated it if an admin look into it, and hopefully fix the problem, and maybe I'll be able to install the board.

Thanks all :P
Best regards,
Greg

Image / iRC ChatRoom
User avatar
z0_redhat
Junior Member
 
Posts: 11
Joined: Wed Jul 12, 2006 4:18 am
Location: USA

Postby zoli » Fri Mar 09, 2007 3:06 pm

Hello,

cgi scripts should be placed into public_html/cgi-bin/ directory.

accepted extensions are: cgi, pl and py

The files need to be executable and the script should take care about the html headers (as usually)

You can debug your cgi script.
read more at http://www.polarhome.com/faq/cache/16.html

Like:

http://www.polarhome.com:793/~dillona/c ... testcgi.pl

the debug version is:
http://www.polarhome.com:793/cgi-bin/cg ... testcgi.pl

Hope this helps.
Regards,
Z
---
Zoltan Arpadffy
zoli
Forum Admin
Forum Admin
 
Posts: 756
Joined: Mon Sep 30, 2002 1:27 am
Location: Stockholm, Sweden


Return to Web development

Who is online

Users browsing this forum: No registered users and 4 guests

cron