Can't access https/ssl site on debian

Troubleshooting with your custom scripts/programs installed on Polarhome.

Moderator: Moderators

Can't access https/ssl site on debian

Postby papa » Fri Nov 28, 2008 4:14 pm

Trying to access my debian web site via HTTPS/SSL at <https://www.polarhome.com:754/~papa> returns an error page:

Failed to Connect

The connection was refused when attempting to contact www.polarhome.com:754.


(Works fine with plain HTTP: <http://www.polarhome.com:753/~papa/>.)

Is the SSL certificate on debian not set up correctly?
User avatar
papa
Senior Member
 
Posts: 142
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka

Postby sjaz » Sat Nov 29, 2008 9:43 pm

Looks like Apache isn't listening on that port at all.

Shall look into it.
User avatar
sjaz
Forum Admin
Forum Admin
 
Posts: 689
Joined: Fri Feb 14, 2003 11:08 pm
Location: London, UK

Postby papa » Sun Nov 30, 2008 7:49 am

Thanks. It will be useful to have HTTPS access working.
User avatar
papa
Senior Member
 
Posts: 142
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka

Postby papa » Sun Dec 07, 2008 4:50 pm

Have you had a chance to look into this problem?
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 142
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka

Postby zoli » Mon Dec 08, 2008 5:51 am

Hello,

as polarhome.com do not have valid certificates... https is not set up at all through polarhome.com.

In fact it used to be set up on some hosts, but I removed about two years ago, when browsers started to send "not recommend site" type of warnings etc. This made more confusion than use :(

I will try to find a good solution for this issues in near future. Maybe purchase a site certificate.

I added this to TODO list.
Regards,
Z
---
Zoltan Arpadffy
zoli
Forum Admin
Forum Admin
 
Posts: 752
Joined: Mon Sep 30, 2002 1:27 am
Location: Stockholm, Sweden

Postby Matej » Mon Dec 08, 2008 7:37 am

Perhaps http://www.startssl.com/?app=0 could be an option. They offer some free certificates and have quite good browser support by default: http://cert.startcom.org/?app=140 . The problem is that IE is not on that list which could be a deal braker. :(
User avatar
Matej
Forum Admin
Forum Admin
 
Posts: 365
Joined: Sun Sep 29, 2002 12:28 am
Location: Ljubljana, Slovenia

Postby papa » Mon Dec 08, 2008 9:36 am

zoli wrote:as polarhome.com do not have valid certificates... https is not set up at all through polarhome.com.

In fact it used to be set up on some hosts, but I removed about two years ago, when browsers started to send "not recommend site" type of warnings etc. This made more confusion than use :(


Thanks for the clarification. This is not an urgent request. I was mainly curious to find HTTPS on the port list.

What I really want is an inexpensive way to SSL-protect a site accessible on the standard HTTPS port 443. I understand that that's not going to be available at Polarhome anytime in the forseeable future.
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 142
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka

Re: Can't access https/ssl site on debian

Postby papa » Sat May 08, 2010 12:02 pm

Currently, I can make SSL connections with Alpha (https://www.polarhome.com:764/) and Redhat (https://www.polarhome.com:794/) servers, so either Zoli didn't remove support from all the hosts or he has set it up on Alpha and Redhat since my original post.

Does this mean that if I get a shell account on Alpha or Redhat I can set up a https site in my personal web space (https://www.polarhome.com:[764|794]/~papa) as long as I'm content to deal with browsers complaining about the certificate? Can the SSL service be considered as stable as any other Polarhome service?
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 142
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka

Re: Can't access https/ssl site on debian

Postby zoli » Wed May 19, 2010 12:20 am

Hello,

basically, I try to enable services that an OS supports by default and add all basic services for "normal usage".
I do not deny services - except a service is violently abused.
Regards,
Z
---
Zoltan Arpadffy
zoli
Forum Admin
Forum Admin
 
Posts: 752
Joined: Mon Sep 30, 2002 1:27 am
Location: Stockholm, Sweden

Re: Can't access https/ssl site on debian

Postby papa » Wed May 19, 2010 2:20 am

(Yay! My reign of forum last post terror is over! :D )

Thanks, Zoli, that's good to know. I am looking forward to playing with my new Alpha and Redhat shell accounts.
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 142
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 2 guests

cron