Closing connection after 5 mins.

No longer supported!

Moderator: Moderators

Postby Stinger » Sat Sep 04, 2004 4:37 pm

I've registered a Mandrake FTP account, and when I use an FTP client (SmartFTP) the connection closes after 300 s. It happens even though I'm uploading files; in the middle of the upload session it just closes, and won't reconnect. I have to cancel the upload session and manually connect again.. This is a little annoying when it comes to uploading many files. :kwasny:

Why is this happening? Is it because it's a FTP account and not Shell?

Regards,
Stinger
Stinger
Newbie
 
Posts: 4
Joined: Sat Sep 04, 2004 4:32 pm

Postby SiNGLeLord » Sat Sep 04, 2004 8:24 pm

Hi,
it isn't because you have FTP acount, you should wait while DenisF will reply... He will fix it ;)
-- Tebunie sviesa! - pasake Bushas ir paspaude raudona mygtuka. (It's some kind of joke)
SiNGLeLord
Advanced Member
 
Posts: 72
Joined: Sun Apr 11, 2004 2:31 am
Location: Lithuania

Postby DenisF » Sat Sep 04, 2004 8:36 pm

Hey,

sounds to me like a setting in your ftp client.
i -do- have an anti-idle thing going on there, but if you're uploading / downloading something, it shouldn't disconnect you.

and there's no distinction between ftp and shell users when it comes to ftp 'permissions'.
Image
[ FAQ ] :: [ Policy ] :: [ Port Forwarding Guide ] :: [ Search ]
User avatar
DenisF
Forum Admin
Forum Admin
 
Posts: 679
Joined: Mon Dec 16, 2002 9:09 pm
Location: Israhell

Postby Stinger » Sun Sep 05, 2004 5:26 pm

I'm trying to upload a PHP-site, with lots of php-files. After a various-from-time-to-time number of uploaded files I get this error message:

<span style='color:red'>500 Illegal PORT command</span>
<span style='color:green'>PORT 192,168,2,10,5,156</span>
<span style='color:red'>Command aborted. Server timeout.
Connection closed. Server timeout.</span>


Any clue as to why this happens? Like I said, it doesn't happen on the same "place" each time.

Stinger

EDIT: I've tried to upload with two different FTP clients, but I still get the same error.
Stinger
Newbie
 
Posts: 4
Joined: Sat Sep 04, 2004 4:32 pm

Postby DenisF » Sun Sep 05, 2004 6:46 pm

Hmm well i just uploaded five copies of phpnuke uncompressed, and i didn't get a single timeout during the upload [even with bandwidth throttling]

I really have no idea where to look :s

can someone else try to upload phpnuke or something like that? see if you get those probs?
Image
[ FAQ ] :: [ Policy ] :: [ Port Forwarding Guide ] :: [ Search ]
User avatar
DenisF
Forum Admin
Forum Admin
 
Posts: 679
Joined: Mon Dec 16, 2002 9:09 pm
Location: Israhell

Postby sjaz » Sun Sep 05, 2004 9:03 pm

okies, ill try it.
User avatar
sjaz
Forum Admin
Forum Admin
 
Posts: 691
Joined: Fri Feb 14, 2003 11:08 pm
Location: London, UK

Postby sjaz » Sun Sep 05, 2004 9:13 pm

[R] TYPE I
[R] 200 Type set to I
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,140,206).
[R] Opening data connection IP: 80.178.84.233 PORT: 36046
[R] STOR PHP-Nuke-7.4.zip
[R] 150 Opening BINARY mode data connection for PHP-Nuke-7.4.zip
[R] 426 Transfer aborted. Operation not permitted
[R] Transfer Failed!
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,140,207).
[R] Opening data connection IP: 80.178.84.233 PORT: 36047
[R] STOR PHP-Nuke-7.4.zip
[R] 150 Opening BINARY mode data connection for PHP-Nuke-7.4.zip
[R] 426 Transfer aborted. Operation not permitted
[R] Transfer Failed!
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,140,208).
[R] Opening data connection IP: 80.178.84.233 PORT: 36048
[R] STOR PHP-Nuke-7.4.zip
[R] 150 Opening BINARY mode data connection for PHP-Nuke-7.4.zip
[R] 426 Transfer aborted. Operation not permitted
[R] Transfer Failed!
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,140,210).
[R] Opening data connection IP: 80.178.84.233 PORT: 36050
[R] STOR PHP-Nuke-7.4.zip
[R] 150 Opening BINARY mode data connection for PHP-Nuke-7.4.zip
[R] 426 Transfer aborted. Operation not permitted
[R] Transfer Failed!
[R] TYPE A
[R] 200 Type set to A
[R] PASV
[R] 227 Entering Passive Mode (192,168,0,111,140,211).
[R] Opening data connection IP: 80.178.84.233 PORT: 36051
[R] LIST -al
[R] 150 Opening ASCII mode data connection for file list
[R] 226 Transfer complete.
[R] List Complete: 299 bytes in 0.88 seconds (0.3 KB/s)
Transfer queue completed
1 File failed to transfer


Seems to happen every 60-90 seconds .... just "dies" then restarts itself.
User avatar
sjaz
Forum Admin
Forum Admin
 
Posts: 691
Joined: Fri Feb 14, 2003 11:08 pm
Location: London, UK

Postby DenisF » Sun Sep 05, 2004 9:24 pm

i meant an uncompressed copy of phpnuke chaz m8, cause it seems that Stinger is uploading multiple files, not a single one.

and you get the 'op not mermitted' cause of this;
[net]
PHP-Nuke-7.4.zip 3.87M
[/etc/proftpd.conf]
# Restrict upload to only 2 megabytes
MaxStoreFileSize 2 Mb
Image
[ FAQ ] :: [ Policy ] :: [ Port Forwarding Guide ] :: [ Search ]
User avatar
DenisF
Forum Admin
Forum Admin
 
Posts: 679
Joined: Mon Dec 16, 2002 9:09 pm
Location: Israhell

Postby sjaz » Mon Sep 06, 2004 9:10 am

Ah, I'll do it when im in from work :).
User avatar
sjaz
Forum Admin
Forum Admin
 
Posts: 691
Joined: Fri Feb 14, 2003 11:08 pm
Location: London, UK

Postby afonic » Mon Sep 06, 2004 2:34 pm

I just tried and it just stucks after some time....
User avatar
afonic
Forum Admin
Forum Admin
 
Posts: 685
Joined: Tue Oct 14, 2003 11:11 pm
Location: Salonica, Greece

Postby DenisF » Mon Sep 06, 2004 2:44 pm

Earlier today, i watched chaz upload phpnuke [16.7mb uncompressed, a shitload of files] in a single session of 58 minutes or so [atleast that's what my logs say]

so i don't think that it's proftpd that's causing problems, it's probably something on your side..
Image
[ FAQ ] :: [ Policy ] :: [ Port Forwarding Guide ] :: [ Search ]
User avatar
DenisF
Forum Admin
Forum Admin
 
Posts: 679
Joined: Mon Dec 16, 2002 9:09 pm
Location: Israhell

Postby sjaz » Mon Sep 06, 2004 6:49 pm

Yup. I left it going when I was at work ... No problems found :)
User avatar
sjaz
Forum Admin
Forum Admin
 
Posts: 691
Joined: Fri Feb 14, 2003 11:08 pm
Location: London, UK

Postby sjaz » Thu Sep 09, 2004 10:47 am

Its cuz my machine and internet connection is elite :P
User avatar
sjaz
Forum Admin
Forum Admin
 
Posts: 691
Joined: Fri Feb 14, 2003 11:08 pm
Location: London, UK

Postby DenisF » Thu Sep 09, 2004 11:05 am

Not as leet as my phone number tho :)
Image
[ FAQ ] :: [ Policy ] :: [ Port Forwarding Guide ] :: [ Search ]
User avatar
DenisF
Forum Admin
Forum Admin
 
Posts: 679
Joined: Mon Dec 16, 2002 9:09 pm
Location: Israhell

Postby sjaz » Thu Sep 09, 2004 3:35 pm

666 ?
User avatar
sjaz
Forum Admin
Forum Admin
 
Posts: 691
Joined: Fri Feb 14, 2003 11:08 pm
Location: London, UK

Postby DenisF » Thu Sep 09, 2004 3:59 pm

200-1337
[too-leet]
Image
[ FAQ ] :: [ Policy ] :: [ Port Forwarding Guide ] :: [ Search ]
User avatar
DenisF
Forum Admin
Forum Admin
 
Posts: 679
Joined: Mon Dec 16, 2002 9:09 pm
Location: Israhell

Postby sjaz » Fri Sep 10, 2004 11:23 am

lmao. :D
User avatar
sjaz
Forum Admin
Forum Admin
 
Posts: 691
Joined: Fri Feb 14, 2003 11:08 pm
Location: London, UK


Return to FTP accounts

Who is online

Users browsing this forum: No registered users and 0 guests

cron