SUSE Shell Request

Support for services available to Shell account users.

Moderator: Moderators

SUSE Shell Request

Postby osp_suse » Tue Sep 25, 2007 11:15 pm

I noticed suse@polarhome is using python v2.4.2. Would it be possible to upgrade to the latest version 2.5.1?

Whats new from 2.4 to 2.5? (Taken From Dummies Book)

*Many Performance Inprovements
*Conditional Expressions
*Absolute Inports
*Updated Exception Hierarchy
*with Statement
*Unified try-except And try-except-finally
*Boolean Functions any() And all()
*Generators have send(), throw(), And close() Methods
*__index__ Special Method
*partition() and rpartition() String Methods
*sqllite3 Package
*ctypes Package
*ElementTree Package
osp_suse
Newbie
 
Posts: 9
Joined: Fri Mar 17, 2006 7:47 pm
Location: United States of America

Postby dillona_aix » Wed Sep 26, 2007 4:48 am

Hi,
I've never written any python, so maybe you could answer this:
Will the update allow existing applications to continue to run?
If its going to break things, the other users need to be alerted.
Best,
Dillon
There are 10 types of people in this world, those who understand binary and those who don't.
User avatar
dillona_aix
Moderator
Moderator
 
Posts: 185
Joined: Sun Sep 11, 2005 9:05 pm
Location: USA

Postby osp_suse » Thu Sep 27, 2007 4:38 am

It should not break any excisting code unless you are using 2.5 code in which case 2.5 code will not run in 2.4, 2.3, and 2.2, but 2.2 and up should run without any modifications on 2.5. I'm not 100% sure though, so i would alert the users anyways just in case.

Michael
osp_suse
Newbie
 
Posts: 9
Joined: Fri Mar 17, 2006 7:47 pm
Location: United States of America

Postby dillona_aix » Tue Oct 02, 2007 2:05 am

That's plenty of time for protests.
However, I can't seem to find RPM's for the new python, so if you see any send them my way.
There are 10 types of people in this world, those who understand binary and those who don't.
User avatar
dillona_aix
Moderator
Moderator
 
Posts: 185
Joined: Sun Sep 11, 2005 9:05 pm
Location: USA

Postby afonic » Wed Oct 03, 2007 2:03 am

Dillon AFAIK only Python 2.4.x comes with openSuse 10.0 (I believe thats what you are using right?). Python 2.5.x was introduced with openSuse 10.2 (again I am not 100% sure).

So you either need to find a backport repo (I don't really know if it exists) or manually compile and install 2.5.x which would make upgrading harder. Of course you could also try to update the whole server to 10.3 (should be released two days from now).

Keep in mind that all Python programs written for 2.4 will work flawlessly for 2.5 as well so no read need to announce it to users.
User avatar
afonic
Forum Admin
Forum Admin
 
Posts: 685
Joined: Tue Oct 14, 2003 11:11 pm
Location: Salonica, Greece

Postby dillona_aix » Sun Oct 07, 2007 7:59 pm

I ended up building from source.
Please give it a try.
There are 10 types of people in this world, those who understand binary and those who don't.
User avatar
dillona_aix
Moderator
Moderator
 
Posts: 185
Joined: Sun Sep 11, 2005 9:05 pm
Location: USA


Return to Shell accounts

Who is online

Users browsing this forum: No registered users and 0 guests

cron