Software request for Debian: libgd, etc.

Support for services available to Shell account users.

Moderator: Moderators

Software request for Debian: libgd, etc.

Postby papa » Tue May 12, 2015 1:56 am

I'm trying to build the MUD server AFKMud on Debian and am having some library and tool dependency problems. Please install the following packages:

autoconf
automake
libpng
libgd

AFKMud requires libgd, which requires the other three. There may be additional dependencies, but I've used up my account quota trying to build this far.
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 142
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka

Re: Software request for Debian: libgd, etc.

Postby zoli » Tue May 12, 2015 6:54 pm

Hi,

no problem at all... I installed the required packages and doubled your quota.
You are welcome :)
Regards,
Z
---
Zoltan Arpadffy
zoli
Forum Admin
Forum Admin
 
Posts: 756
Joined: Mon Sep 30, 2002 1:27 am
Location: Stockholm, Sweden

Re: Software request for Debian: libgd, etc.

Postby papa » Tue May 12, 2015 7:47 pm

Thank you!

Onward and upward!
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 142
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka

Re: Software request for Debian: libgd, etc.

Postby papa » Wed May 13, 2015 2:03 am

Hmm, are you sure libgd got installed correctly? I don't see gd.h in any of the likely directories.

Installing libgd in my own account lets me compile AFKMud, but I get the following error when trying to run it:
Code: Select all
../src/afkmud: error while loading shared libraries: libgd.so.3: cannot open shared object file: No such file or directory

...which will maybe go away if libgd is set up correctly for the whole Debian server, hopefully.
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 142
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka

Re: Software request for Debian: libgd, etc.

Postby zoli » Fri May 15, 2015 8:09 am

Hmmm strange.

I forced the reinstall of libgd2-xpm-dev hope it helps.

To run with your own libs you need to set the LD_LIBRARY_PATH environment variable.
Regards,
Z
---
Zoltan Arpadffy
zoli
Forum Admin
Forum Admin
 
Posts: 756
Joined: Mon Sep 30, 2002 1:27 am
Location: Stockholm, Sweden

Re: Software request for Debian: libgd, etc.

Postby papa » Tue May 19, 2015 8:49 am

zoli wrote:Hmmm strange.

I forced the reinstall of libgd2-xpm-dev hope it helps.

To run with your own libs you need to set the LD_LIBRARY_PATH environment variable.


AFKMud still won't run with the system shared libgd, but the LD_LIBRARY_PATH trick allows me to run the program with the llibgd I installed in my own account.
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 142
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka


Return to Shell accounts

Who is online

Users browsing this forum: No registered users and 3 guests

cron