Java on ALPHA

Support for services available to Shell account users.

Moderator: Moderators

Java on ALPHA

Postby papa » Fri Nov 23, 2018 3:17 pm

I knew that ALPHA had Java installed, but previous attempts to compile a small hello program terminated with the error, "Unable to initialize threads: cannot find class java/lang/Thread".

Today I looked up that error message and discovered that it's caused by not having CLASSPATH set, so I entered the following command and tried compiling again:

$ define java$classpath .,sys$common:[java$131.lib]tools.jar,sys$common[java$131.lib]dt.jar,sys$common:[java$131.jre.lib]rt.jar

Now JAVAC starts, but terminates with the following output:

JAVAC output =======================
Code: Select all
SIGBUS    10*  bus error

Full thread dump:
Monitor Cache Dump:
Registered Monitor Dump:
    Name and type hash table lock: <unowned>
    String intern lock: <unowned>
    JNI pinning lock: <unowned>
    JNI global reference lock: <unowned>
    BinClass lock: <unowned>
    Class loading lock: <unowned>
    Java stack lock: <unowned>
    Code rewrite lock: <unowned>
    Heap lock: <unowned>
    Has finalization queue lock: <unowned>
    Finalize me queue lock: <unowned>
    Monitor registry: <unowned>
%SYSTEM-F-OPCCUS, opcode reserved to customer fault at PC=FFFFFFFF80A50C24, PS=0
000001B

  Improperly handled condition, image exit forced.
    Signal arguments:   Number = 0000000000000003
                        Name   = 0000000000000434
                                 FFFFFFFF80A50C24
                                 000000000000001B

    Register dump:
    R0  = 0000000000000001  R1  = 000000007B8FC1F8  R2  = 000000007BF55B68
    R3  = FFFFFFFFFFFFFFFE  R4  = FFFFFFFFFFFFFFFE  R5  = 0000000000000434
    R6  = 0000000000000001  R7  = 000000007B8F6020  R8  = 000000007BFC2490
    R9  = 000000007BFC2490  R10 = 0000000000000000  R11 = 0000000000000000
    R12 = 00000000001CF5D0  R13 = 00000000009C2C74  R14 = 00000000009C2824
    R15 = 0000000000000000  R16 = 0000000000000434  R17 = FFFFFFFF80A509D0
    R18 = 0000000000000000  R19 = 0000000000000002  R20 = 0000000000000000
    R21 = 000000007BFC0708  R22 = 0000000000000001  R23 = 0000000000000000
    R24 = 0000000000000000  R25 = 0000000000000001  R26 = FFFFFFFF80A50C24
    R27 = 000000007B58CE00  R28 = 000000000000001B  R29 = 000000007AE71FC0
    SP  = 000000007AE71FC0  PC  = FFFFFFFF80A50C24  PS  = 000000000000001B

End of JAVAC output ========================

Looking up "SIGBUS 10* bus error", I find no definite solution, but learned that our Java (version 1.1.8-5) is VERY old. Any chance we could install a newer version?
David "papa" Meyer
Takarazuka, Japan
papa@ alpha | ia64 |debian | netbsd | redhat | vax
User avatar
papa
Senior Member
 
Posts: 149
Joined: Mon Apr 14, 2008 8:55 pm
Location: Japan Takarazuka

Return to Shell accounts

Who is online

Users browsing this forum: No registered users and 0 guests

cron