BUF_ISLOCKED man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

BUF_ISLOCKED(9)		 BSD Kernel Developer's Manual	       BUF_ISLOCKED(9)

NAME
     BUF_ISLOCKED — returns the state of the lock linked to the buffer

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <sys/uio.h>
     #include <sys/bio.h>
     #include <sys/buf.h>

     int
     BUF_ISLOCKED(struct buf *bp);

DESCRIPTION
     The BUF_ISLOCKED() function returns the status of the lock linked to the
     buffer in relation to curthread.

     It can return:

     LK_EXCLUSIVE  An exclusive lock is held by curthread.

     LK_EXCLOTHER  An exclusive lock is held by someone other than curthread

     LK_SHARED	   A shared lock is held.

     0		   The lock is not held by anyone.

SEE ALSO
     lockstatus(9), buf(9), BUF_LOCK(9), BUF_UNLOCK(9), lockmgr(9)

AUTHORS
     This manual page was written by Attilio Rao ⟨attilio@FreeBSD.org⟩.

BSD			       January 22, 2008				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net