BUF_ISLOCKED(9) BSD Kernel Developer's Manual BUF_ISLOCKED(9)NAMEBUF_ISLOCKED — returns the state of the lock linked to the buffer
BUF_ISLOCKED(struct buf *bp);
The BUF_ISLOCKED() function returns the status of the lock linked to the
buffer in relation to curthread.
It can return:
LK_EXCLUSIVE An exclusive lock is held by curthread.
LK_EXCLOTHER An exclusive lock is held by someone other than curthread
LK_SHARED A shared lock is held.
0 The lock is not held by anyone.
SEE ALSOlockstatus(9), buf(9), BUF_LOCK(9), BUF_UNLOCK(9), lockmgr(9)AUTHORS
This manual page was written by Attilio Rao ⟨attilio@FreeBSD.org⟩.
BSD January 22, 2008 BSD