BUF_LOCK man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

BUF_LOCK(9)		 BSD Kernel Developer's Manual		   BUF_LOCK(9)

NAME
     BUF_LOCK — locks a buffer

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <sys/uio.h>
     #include <sys/bio.h>
     #include <sys/buf.h>

     int
     BUF_LOCK(struct buf *bp, int locktype);

DESCRIPTION
     The BUF_LOCK() function locks the given buffer.  If the lock is already
     held this call will block until it can acquire the lock unless LK_NOWAIT
     is set.

     Its arguments are:

     bp	       The buffer to lock.

     locktype  Flags controlling the type of lock.  See lockmgr(9) for
	       details.

RETURN VALUES
     A value of 0 is returned upon success.  See lockmgr(9) for information on
     non-zero return values.

SEE ALSO
     buf(9), BUF_TIMELOCK(9), BUF_UNLOCK(9), lockmgr(9)

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 July 9, 2001				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net