BUF_LOCKINIT man page on FreeBSD

Printed from http://www.polarhome.com/service/man/?qf=BUF_LOCKINIT&af=0&tf=2&of=FreeBSD

BUF_LOCKINIT(9)		 BSD Kernel Developer's Manual	       BUF_LOCKINIT(9)

NAME
     BUF_LOCKINIT — initializes a buffer lock

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <sys/uio.h>
     #include <sys/bio.h>
     #include <sys/buf.h>

     void
     BUF_LOCKINIT(struct buf *bp);

DESCRIPTION
     The BUF_LOCKINIT() macro initializes a buffer lock.

     Its argument is:

     bp	 The buffer whose lock it to be initialized.

SEE ALSO
     buf(9), BUF_LOCK(9), BUF_TIMELOCK(9), BUF_UNLOCK(9), lockinit(9),
     lockmgr(9)

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				January 6, 2005				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net