BUF_UNLOCK man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

BUF_UNLOCK(9)		 BSD Kernel Developer's Manual		 BUF_UNLOCK(9)

NAME
     BUF_UNLOCK — unlocks a locked buffer

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <sys/uio.h>
     #include <sys/bio.h>
     #include <sys/buf.h>

     void
     BUF_UNLOCK(struct buf *bp);

DESCRIPTION
     The BUF_UNLOCK() function unlocks a buffer that was previously locked
     with BUF_LOCK() or BUF_TIMELOCK().

     Its argument is:

     bp	 The buffer to unlock.	The buffer must already be locked.

SEE ALSO
     buf(9), BUF_LOCK(9), BUF_TIMELOCK(9), lockmgr(9)

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 July 9, 2001				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net