BUS_PRINT_CHILD man page on PC-BSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
PC-BSD logo
[printable version]

BUS_PRINT_CHILD(9)	 BSD Kernel Developer's Manual	    BUS_PRINT_CHILD(9)

NAME
     BUS_PRINT_CHILD — print information about a device

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     BUS_PRINT_CHILD(device_t dev, device_t child);

DESCRIPTION
     The BUS_PRINT_CHILD() method is called from system code which prints out
     a description of a device.	 It should describe the attachment that the
     child has with the parent.	 For instance the TurboLaser bus prints which
     node the device is attached to.  Please see bus_generic_print_child(9)
     for more information regarding the proper formatting of the messages
     printed by BUS_PRINT_CHILD().

RETURN VALUES
     The number of characters output.

SEE ALSO
     device(9), driver(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				January 6, 2005				   BSD
[top]

List of man pages available for PC-BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net