CLTP man page on 4.4BSD

Man page or keyword search:  
man Server   1065 pages
apropos Keyword Search (all sections)
Output format
4.4BSD logo
[printable version]

CLTP(4)			 BSD Kernel Interfaces Manual		       CLTP(4)

NAME
     cltp — ISO Connectionless Transport Protocol

SYNOPSIS
     #include <sys/socket.h>
     #include <netiso/iso.h>

     int
     socket(AF_ISO, SOCK_DGRAM, 0);

DESCRIPTION
     CLTP is a simple, unreliable datagram protocol which is accessed via the
     SOCK_DGRAM abstraction for the ISO protocol family.  CLTP sockets are
     connectionless, and are normally used with the sendto and recvfrom calls,
     though the connect(2) call may also be used to fix the destination for
     future packets (in which case the recv(2) or read(2) and send(2) or
     write(2) system calls may be used).

     CLTP address formats are identical to those used by TP.  In particular
     CLTP provides a service selector in addition to the normal ISO NSAP.
     Note that the CLTP selector space is separate from the TP selector space
     (i.e. a CLTP selector may not be “connected” to a TP selector).

     Options at the CLNP network level may be used with CLTP; see clnp(4).

DIAGNOSTICS
     A socket operation may fail with one of the following errors returned:

     [EISCONN]	      when trying to establish a connection on a socket which
		      already has one, or when trying to send a datagram with
		      the destination address specified and the socket is
		      already connected;

     [ENOTCONN]	      when trying to send a datagram, but no destination
		      address is specified, and the socket hasn't been con‐
		      nected;

     [ENOBUFS]	      when the system runs out of memory for an internal data
		      structure;

     [EADDRINUSE]     when an attempt is made to create a socket with a selec‐
		      tor which has already been allocated;

     [EADDRNOTAVAIL]  when an attempt is made to create a socket with a net‐
		      work address for which no network interface exists.

SEE ALSO
     getsockopt(2), recv(2), send(2), socket(2), intro(4), iso(4), clnp(4)

BSD				 June 9, 1993				   BSD
[top]

List of man pages available for 4.4BSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net