DEVICE_ATTACH man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

DEVICE_ATTACH(9)	 BSD Kernel Developer's Manual	      DEVICE_ATTACH(9)

NAME
     DEVICE_ATTACH — attach a device

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     int
     DEVICE_ATTACH(device_t dev);

DESCRIPTION
     Attach a device to the system.  The probe method will have been called
     and will have indicated that the device exists.  This routine should ini‐
     tialise the hardware and allocate other system resources (such as /dev
     entries).

RETURN VALUES
     Zero is returned on success, otherwise an appropriate error is returned.

SEE ALSO
     device(9), DEVICE_DETACH(9), DEVICE_PROBE(9)

AUTHORS
     This man page was written by Doug Rabson.

BSD				 June 16, 1998				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net