GET_CYCLECOUNT man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

GET_CYCLECOUNT(9)	 BSD Kernel Developer's Manual	     GET_CYCLECOUNT(9)

NAME
     get_cyclecount — get the CPU's fast counter register contents

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <machine/cpu.h>

     u_int64_t
     get_cyclecount(void);

DESCRIPTION
     The get_cyclecount() function uses a register available in most modern
     CPUs to return a value that is monotonically increasing inside each CPU.

     On SMP systems, there will be a number of separate monotonic sequences,
     one for each CPU running.	The value in the SMP case is selected from one
     of these sequences, dependent on which CPU was scheduled to service the
     request.

     The speed and the maximum value of each counter is CPU-dependent.	Some
     CPUs (such as the Intel 80486) do not have such a register, so
     get_cyclecount() on these platforms returns the number of nanoseconds
     represented by the structure returned by nanotime(9).

     The Pentium processors all use the TSC register.

     The Alpha processors use the PCC register.

     The IA64 processors use the AR.ITC register.

SEE ALSO
     nanotime(9)

HISTORY
     The get_cyclecount() function first appeared in FreeBSD 5.0.

AUTHORS
     This manual page was written by Mark Murray ⟨markm@FreeBSD.org⟩.

BSD			       November 20, 2000			   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net