KLDUNLOAD(8) BSD System Manager's Manual KLDUNLOAD(8)NAME
kldunload — unload a file from the kernel
kldunload [-fv] -i id ...
kldunload [-fv] [-n] name ...
The kldunload utility unloads a file which was previously loaded with
The following options are available:
-f Force the unload. This ignores error returns to MOD_QUIESCE
from the module and implies that the module should be unloaded
even if it is currently in use. The users are left to cope as
best they can.
-v Be more verbose.
-i id Unload the file with this ID.
-n name Unload the file with this name.
name Unload the file with this name.
The kldunload utility exits 0 on success, and >0 if an error occurs.
SEE ALSOkldunload(2), kldload(8), kldstat(8)HISTORY
The kldunload utility first appeared in FreeBSD 3.0, replacing the lkm
Doug Rabson ⟨dfr@FreeBSD.org⟩
BSD February 27, 2006 BSD