MALLOC_DEFINE man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

KMALLOC(9)		 BSD Kernel Developer's Manual		    KMALLOC(9)

NAME
     kmalloc, MALLOC, kfree, FREE, krealloc, MALLOC_DEFINE, MALLOC_DECLARE —
     kernel memory management routines

SYNOPSIS
     #include <sys/types.h>
     #include <sys/malloc.h>

     void *
     kmalloc(unsigned long size, struct malloc_type *type, int flags);

     MALLOC(space, cast, unsigned long size, struct malloc_type *type,
	 int flags);

     void
     kfree(void *addr, struct malloc_type *type);

     FREE(void *addr, struct malloc_type *type);

     void *
     krealloc(void *addr, unsigned long size, struct malloc_type *type,
	 int flags);

     MALLOC_DECLARE(type);

     #include <sys/param.h>
     #include <sys/malloc.h>
     #include <sys/kernel.h>

     MALLOC_DEFINE(type, shortdesc, longdesc);

DESCRIPTION
     The kmalloc() function allocates uninitialized memory in kernel address
     space for an object whose size is specified by size.

     The kfree() function releases memory at address addr that was previously
     allocated by kmalloc() for re-use.	 The memory is not zeroed.  The kernel
     implementation of kfree() does not allow addr to be NULL.

     The krealloc() function changes the size of the previously allocated mem‐
     ory referenced by addr to size bytes.  The contents of the memory are
     unchanged up to the lesser of the new and old sizes.  Note that the
     returned value may differ from addr.  If the requested memory cannot be
     allocated, NULL is returned and the memory referenced by addr is valid
     and unchanged.  If addr is NULL, the krealloc() function behaves identi‐
     cally to kmalloc() for the specified size.

     The MALLOC() macro variant is functionally equivalent to

	   (space) = (cast)kmalloc((u_long)(size), type, flags)

     and the FREE() macro variant is equivalent to

	   kfree((addr), type)

     Unlike its standard C library counterpart (malloc(3)), the kernel version
     takes two more arguments.	The flags argument further qualifies
     kmalloc()'s operational characteristics as follows:

     M_ZERO  Causes the allocated memory to be set to all zeros.

     M_NOWAIT
	     Causes kmalloc() and krealloc(), to return NULL if the request
	     cannot be immediately fulfilled due to resource shortage.	Note
	     that M_NOWAIT is required when running in an interrupt context.

     M_WAITOK
	     Indicates that it is OK to wait for resources.  If the request
	     cannot be immediately fulfilled, the current process is put to
	     sleep to wait for resources to be released by other processes.
	     The kmalloc() and krealloc(), functions cannot return NULL if
	     M_WAITOK is specified.

     M_INTWAIT
	     Indicates kmalloc() to dig into the system's reserved free pages
	     looking for enough room to perform the allocation.	 This is typi‐
	     cally used in interrupts where you cannot afford kmalloc() to
	     fail.

     M_USE_RESERVE
	     Indicates that the system can dig into its reserve in order to
	     obtain the requested memory.  This option used to be called
	     M_KERNEL but has been renamed to something more obvious.  This
	     option has been deprecated and is slowly being removed from the
	     kernel, and so should not be used with any new code.

     Exactly one of either M_WAITOK or M_NOWAIT must be specified.

     The type argument is used to perform statistics on memory usage, and for
     basic sanity checks.  It can be used to identify multiple allocations.
     The statistics can be examined by ‘vmstat -m’.

     A type is defined using the malloc_type_t typedef via the
     MALLOC_DECLARE() and MALLOC_DEFINE() macros.

	   /* sys/something/foo_extern.h */

	   MALLOC_DECLARE(M_FOOBUF);

	   /* sys/something/foo_main.c */

	   MALLOC_DEFINE(M_FOOBUF, "foobuffers", "Buffers to foo data into the ether");

	   /* sys/something/foo_subr.c */

	   ...
	   MALLOC(buf, struct foo_buf *, sizeof *buf, M_FOOBUF, M_NOWAIT);

IMPLEMENTATION NOTES
     The memory allocator allocates memory in chunks that have size a power of
     two for requests up to the size of a page of memory.  For larger
     requests, one or more pages is allocated.	While it should not be relied
     upon, this information may be useful for optimizing the efficiency of
     memory use.

RETURN VALUES
     The kmalloc() and krealloc(), functions return a kernel virtual address
     that is suitably aligned for storage of any type of object, or NULL if
     the request could not be satisfied (implying that M_NOWAIT was set).

DIAGNOSTICS
     A kernel compiled with the INVARIANTS configuration option attempts to
     detect memory corruption caused by such things as writing outside the
     allocated area and imbalanced calls to the kmalloc() and kfree() func‐
     tions.  Failing consistency checks will cause a panic or a system console
     message.

SEE ALSO
     vmstat(8), contigmalloc(9), memory(9), vnode(9)

BSD			       January 15, 2010				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net