PANIC man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

PANIC(9)		 BSD Kernel Developer's Manual		      PANIC(9)

NAME
     panic — bring down system on fatal error

SYNOPSIS
     #include <sys/types.h>
     #include <sys/systm.h>

     void
     panic(const char *fmt, ...);

DESCRIPTION
     The panic() function terminates the running system.  The message fmt is a
     printf(3) style format string.  The message is printed to the console and
     the location panicstr is set to the address of the message text for
     retrieval from the OS core dump.

     If the kernel debugger is installed control is passed to it, otherwise an
     attempt to save a core dump of the OS to a configured dump device is
     made.

     If panic() is called twice (from the disk sync routines, for example) the
     system is rebooted without syncing the disks.

RETURN VALUES
     The panic() function does not return.

BSD				August 11, 1995				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net