WATCHDOG(4) BSD Kernel Interfaces Manual WATCHDOG(4)NAME
watchdog — hardware and software watchdog
The watchdog facility is used for controlling hardware and software
/dev/fido responds to a single ioctl(2) call, WDIOCPATPAT. It takes a
single argument which represents a timeout value specified as a power of
two nanoseconds, or-ed with a flag selecting active or passive control of
WD_ACTIVE indicates that the watchdog will be kept from timing out from
userland, for instance by the watchdogd(8) daemon. WD_PASSIVE indicates
that the watchdog will be kept from timing out from the kernel.
The ioctl(2) call will return success if just one of the available
watchdog(9) implementations supports setting the timeout to the specified
timeout. This means that at least one watchdog is armed. If the call
fails, for instance if none of watchdog(9) implementations support the
timeout length, all watchdogs are disabled and must be explicitly re-
To disable the watchdogs pass WD_TO_NEVER. If disarming the watchdog(s)
failed an error is returned. The watchdog might still be armed!
The ioctl returns zero on success and non-zero on failure.
[EOPNOTSUPP] No watchdog present in the kernel (timeout value other
[EOPNOTSUPP] Watchdog could not be disabled (timeout value of 0).
[EINVALID] Invalid flag combination passed.
[EINVALID] None of the watchdogs supports the requested timeout
#define WDPATH "/dev/" _PATH_WATCHDOG
int wdfd = -1;
wdfd = open(WDPATH, O_RDWR);
if (wdfd == -1)
if (ioctl(wdfd, WDIOCPATPAT, &timeout) == -1)
/* in main() */
/* potential freeze point */
Enables a watchdog to recover from a potentially freezing piece of code.
in your kernel config adds a software watchdog in the kernel, dropping to
KDB or panic-ing when firing.
SEE ALSOwatchdogd(8), watchdog(9)HISTORY
The watchdog code first appeared in FreeBSD 5.1.
The WD_PASSIVE option has not yet been implemented.
The watchdog facility was written by Poul-Henning Kamp ⟨phk@FreeBSD.org⟩.
The software watchdog code and this manual page were written by Sean
Kelly ⟨smkelly@FreeBSD.org⟩. Some contributions were made by Jeff
BSD June 25, 2003 BSD