ACPI_TOSHIBA(4) BSD/i386 Kernel Interfaces Manual ACPI_TOSHIBA(4)NAMEacpi_toshiba — Toshiba HCI interface
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
HCI is Toshiba's Hardware Control Interface which is somewhat uniform
across their models. The acpi_toshiba driver allows the user to manipu‐
late HCI-controlled hardware using a number of sysctl(8) variables.
The following sysctls are currently implemented:
Causes active cooling to be forcibly enabled (‘1’) or disabled
(‘0’) regardless of the current temperature.
Sets the active display to use according to a bitwise OR of the
0 No display
Only some systems (i.e., the Libretto L5) support video switching
via this hardware-specific driver. Use the acpi_video(4) driver
for generic video output support.
Makes the LCD backlight brighter or dimmer (higher values are
Turns the LCD backlight on and off.
Sets the CPU speed to the specified speed. This provides func‐
tionality similar to the hw.acpi.cpu.throttle_state variable.
Higher sysctl values mean lower CPU speeds.
Defaults for these variables can be set in sysctl.conf(5), which is
parsed at boot-time.
The hw.acpi.toshiba.enable_fn_keys tunable enables or disables the func‐
tion keys on the keyboard. Function keys are enabled by default.
This behaviour can be changed at the loader(8) prompt or in
SEE ALSOacpi(4), acpi_video(4), loader.conf(5), sysctl.conf(5), sysctl(8)HISTORY
The acpi_toshiba driver first appeared in FreeBSD 5.1.
The acpi_toshiba driver was written by Hiroyuki Aizu ⟨email@example.com⟩.
This manual page was written by Philip Paeps ⟨philip@FreeBSD.org⟩.
BSD February 19, 2004 BSD