ADA(4) BSD Kernel Interfaces Manual ADA(4)NAMEada — ATA Direct Access device driver
The ada driver provides support for direct access devices, implementing
the ATA command protocol, that are attached to the system through a host
adapter supported by the CAM subsystem.
The host adapter must also be separately configured into the system
before an ATA direct access device can be configured.
Command queueing allows the device to process multiple transactions con‐
currently, often re-ordering them to reduce the number and length of
seeks. ATA defines two types of queueing: TCQ (Tagged Command Queueing,
PATA legacy) and NCQ (Native Command Queueing, SATA). The ada device
driver takes full advantage of NCQ, when supported. To ensure that
transactions to distant parts of the media, which may be deferred indefi‐
nitely by servicing requests closer to the current head position, are
completed in a timely fashion, an ordered transaction is sent every 7
seconds during continuous device operation.
Many direct access devices are equipped with read and/or write caches.
Parameters affecting the device's cache are reported in device IDENTIFY
data and can be examined and modified via the camcontrol(8) utility.
The read cache is used to store data from device-initiated read ahead
operations as well as frequently used data. The read cache is transpar‐
ent to the user and can be enabled without any adverse effect. Most
devices with a read cache come from the factory with it enabled.
The write cache can greatly decrease the latency of write operations and
allows the device to reorganize writes to increase efficiency and perfor‐
mance. This performance gain comes at a price. Should the device lose
power while its cache contains uncommitted write operations, these writes
will be lost. The effect of a loss of write transactions on a file sys‐
tem is non-deterministic and can cause corruption. Most devices age
write transactions to limit the vulnerability to a few transactions
recently reported as complete, but it is nonetheless recommended that
systems with write cache enabled devices reside on an Uninterruptible
Power Supply (UPS). The ada device driver ensures that the cache and
media are synchronized upon final close of the device or an unexpected
shutdown (panic) event. This ensures that it is safe to disconnect power
once the operating system has reported that it has halted.
The following variables are available as both sysctl(8) variables and
This variable determines how many times the ada driver will retry a
READ or WRITE command. This does not affect the number of retries
used during probe time or for the ada driver dump routine. This
value currently defaults to 4.
This variable determines how long the ada driver will wait before
timing out an outstanding command. The units for this value are sec‐
onds, and the default is currently 30 seconds.
This variable determines whether to spin-down disks when shutting
down. Set to 1 to enable spin-down, 0 to disable. The default is
/dev/ada* ATA device nodes
SEE ALSOad(4), ahci(4), cam(4), da(4), siis(4)HISTORY
The ada driver first appeared in FreeBSD 8.0.
Alexander Motin ⟨mav@FreeBSD.org⟩
BSD October 24, 2010 BSD