ADB(4) OpenBSD Programmer's Manual (Mac68k) ADB(4)NAMEadb - Apple Desktop Bus driver
adb0 at obio?
akbd* at adb?
ams* at adb?
The Apple Desktop Bus (ADB) is the single-master, multiple-slave, low-
speed serial bus interface used by Macintosh computers to connect input
devices such as keyboards, mice, trackballs, and graphics tablets to the
OpenBSD provides support for the following devices:
akbd(4) Apple Keyboard Device
ams(4) Apple Mouse Support
The adb interface first appeared in NetBSD 0.9.
Bradley A. Grantham wrote the original adb driver, including the MRG
support. The hardware direct interface was written by John P.
Wittkowski. The PowerManager interface was written by Takashi Hamada.
o Not every class of ADB hardware is supported yet.
o The talk command is currently unimplemented.
o The listen command is not implemented yet.
OpenBSD 4.9 May 31, 2007 OpenBSD 4.9