ADDUSER(8) BSD System Manager's Manual ADDUSER(8)NAMEadduser — procedure for adding new users
A new user must choose a login name, which must not already appear in
/etc/passwd or /etc/aliases. It must also not begin with the hyphen ‘-’
character. It is strongly recommended that it be all lower-case, and not
contain the dot ‘.’ character, as that tends to confuse mailers. An
account can be added by editing a line into the passwd file; this must be
done with the password file locked e.g. by using chpass(1) or vipw(8).
A new user is given a group and user id. Login and user id's should be
unique across the system, and often across a group of systems, since they
are used to control file access. Typically, users working on similar
projects will be put in the same groups. At the University of Califor‐
nia, Berkeley, we have groups for system staff, faculty, graduate stu‐
dents, and special groups for large projects.
A skeletal account for a new user ernie might look like:
ernie::25:30::0:0:Ernie Kovacs,508 Evans Hall,x7925,
For a description of each of these fields, see passwd(5).
It is useful to give new users some help in getting started, supplying
them with a few skeletal files such as .profile if they use /bin/sh, or
.cshrc and .login if they use /bin/csh. The directory /usr/share/skel
contains skeletal definitions of such files. New users should be given
copies of these files which, for instance, use tset(1) automatically at
/etc/master.passwd user database
/usr/share/skel skeletal login directory
SEE ALSOchpass(1), finger(1), passwd(1), aliases(5), passwd(5), pwd_mkdb(8),
User information should (and eventually will) be stored elsewhere.
The adduser command appeared in 3.0BSD.
4th Berkeley Distribution June 5, 1993 4th Berkeley Distribution