AMAS(4) OpenBSD Programmer's Manual AMAS(4)NAMEamas - AMD memory address map
amas* at pci?
The amas driver provides read access to the AMD memory map, which
describes the location of physical memory.
One instance of this device is shared between all cores on a chip. This
device is present on AMD processors of the 0Fh, 10h and 11h family.
The amas device can run in either interleaved mode or in non-interleaved
mode. In interleaved mode, the physical memory addresses are rotated
across each chip. amas sits between the CPU cores, the dram controller
and the hypertransport bus. When a CPU requests a memory page, amas
decides if the request is serviced from memory local to the chip, in
which case it normalizes the address and passes it on to the dram
controller. If the request refers to memory present on a different chip,
the request is forwarded to the correct chip using the hypertransport
The amas device is configured by the BIOS and kernel startup routines.
If multiple instances of this device are available, all should contain
the same information.
BIOS and Kernel Developer's Guide for AMD Athlon 64 and AMD Opteron
Processors, Publication # 26094, pp. 66-80, February 2006.
BIOS and Kernel Developer's Guide (BKDG) For AMD Family 10h Processors,
Publication # 31116, pp. 158-167, March 2008.
BIOS and Kernel Developer's Guide (BKDG) For AMD Family 11h Processors,
Publication # 41256, pp. 109-114, July 2008.
The amas driver first appeared in OpenBSD 4.6.
The amas driver was written by Ariane van der Steldt <email@example.com>.
OpenBSD 4.9 May 7, 2009 OpenBSD 4.9