AMR(4) BSD Kernel Interfaces Manual AMR(4)NAMEamr — MegaRAID SCSI/ATA/SATA RAID driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The amr driver provides support for LSI Logic MegaRAID SCSI, ATA and SATA
RAID controllers and legacy American Megatrends MegaRAID SCSI RAID con‐
trollers, including models relabeled and sold by Dell and Hewlett-
LSI MegaRAID SAS controllers are supported by mfi(4) and will not work
with this driver.
Controllers supported by the amr driver include:
· MegaRAID SATA 150-4
· MegaRAID SATA 150-6
· MegaRAID SATA 300-4X
· MegaRAID SATA 300-8X
· MegaRAID SCSI 320-1E
· MegaRAID SCSI 320-2E
· MegaRAID SCSI 320-4E
· MegaRAID SCSI 320-0X
· MegaRAID SCSI 320-2X
· MegaRAID SCSI 320-4X
· MegaRAID SCSI 320-0
· MegaRAID SCSI 320-1
· MegaRAID SCSI 320-2
· MegaRAID SCSI 320-4
· MegaRAID Series 418
· MegaRAID i4 133 RAID
· MegaRAID Elite 1500 (Series 467)
· MegaRAID Elite 1600 (Series 493)
· MegaRAID Elite 1650 (Series 4xx)
· MegaRAID Enterprise 1200 (Series 428)
· MegaRAID Enterprise 1300 (Series 434)
· MegaRAID Enterprise 1400 (Series 438)
· MegaRAID Enterprise 1500 (Series 467)
· MegaRAID Enterprise 1600 (Series 471)
· MegaRAID Express 100 (Series 466WS)
· MegaRAID Express 200 (Series 466)
· MegaRAID Express 300 (Series 490)
· MegaRAID Express 500 (Series 475)
· Dell PERC
· Dell PERC 2/SC
· Dell PERC 2/DC
· Dell PERC 3/DCL
· Dell PERC 3/QC
· Dell PERC 4/DC
· Dell PERC 4/IM
· Dell PERC 4/SC
· Dell PERC 4/Di
· Dell PERC 4e/DC
· Dell PERC 4e/Di
· Dell PERC 4e/Si
· Dell PERC 4ei
· HP NetRAID-1/Si
· HP NetRAID-3/Si (D4943A)
· HP Embedded NetRAID
· Intel RAID Controller SRCS16
· Intel RAID Controller SRCU42X
Driver initialisation/shutdown phase
amr%d: memory window not available
amr%d: I/O window not available
The PCI BIOS did not allocate resources necessary for the correct opera‐
tion of the controller. The driver cannot attach to this controller.
amr%d: busmaster bit not set, enabling
The PCI BIOS did not enable busmaster DMA, which is required for the cor‐
rect operation of the controller. The driver has enabled this bit and
initialisation will proceed.
amr%d: can't allocate register window
amr%d: can't allocate interrupt
amr%d: can't set up interrupt
amr%d: can't allocate parent DMA tag
amr%d: can't allocate buffer DMA tag
amr%d: can't allocate scatter/gather DMA tag
amr%d: can't allocate s/g table
amr%d: can't allocate mailbox tag
amr%d: can't allocate mailbox memory
A resource allocation error occurred while initialising the driver; ini‐
tialisation has failed and the driver will not attach to this controller.
amr%d: can't obtain configuration data from controller
amr%d: can't obtain product data from controller
The driver was unable to obtain vital configuration data from the con‐
troller. Initialisation has failed and the driver will not attach to
amr%d: can't establish configuration hook
amr%d: can't scan controller for drives
The scan for logical drives managed by the controller failed. No drives
will be attached.
amr%d: device_add_child failed
amr%d: bus_generic_attach returned %d
Creation of the logical drive instances failed; attachment of one or more
logical drives may have been aborted.
amr%d: flushing cache...
The controller cache is being flushed prior to shutdown or detach.
amr%d: I/O beyond end of unit (%u,%d > %u)
A partitioning error or disk corruption has caused an I/O request beyond
the end of the logical drive. This may also occur if FlexRAID Virtual
Sizing is enabled and an I/O operation is attempted on a portion of the
virtual drive beyond the actual capacity available.
amr%d: polled command timeout
An initialisation command timed out. The initialisation process may fail
as a result.
amr%d: bad slot %d completed
The controller reported completion of a command that the driver did not
issue. This may result in data corruption, and suggests a hardware or
firmware problem with the system or controller.
amr%d: I/O error - %x
An I/O error has occurred.
SEE ALSOcd(4), da(4), mfi(4), sa(4), scsi(4)AUTHORS
The amr driver was written by Mike Smith ⟨msmith@FreeBSD.org⟩.
This manual page was written by Mike Smith ⟨msmith@FreeBSD.org⟩ and
Jeroen Ruigrok van der Werven ⟨asmodai@FreeBSD.org⟩.
BSD March 29, 2006 BSD