AN(4) OpenBSD Programmer's Manual AN(4)NAMEan - Aironet Communications 4500/4800 IEEE 802.11FH/b wireless network
an* at pcmcia?
an* at pci?
an* at isapnp?
The an driver provides support for the Aironet Communications 4500, 4800
(aka Cisco 340), and Cisco 350 IEEE 802.11 wireless network adapters.
This includes the ISA, PCI, and PCMCIA varieties. The 4500 series
adapters operate at 1 and 2Mbps (FH) while the 4800 and 350 series can
operate at 1, 2, 5.5, and 11Mbps (DS). The ISA, PCI, and PCMCIA devices
are all based on the same core PCMCIA modules and all have the same
programming interface. However, unlike the Lucent WaveLAN/IEEE cards,
the ISA and PCI cards appear to the host as normal ISA and PCI devices
and do not require any PCMCIA support.
ISA cards can either be configured to use ISA Plug and Play or to use a
particular I/O address and IRQ by properly setting the DIP switches on
the board. (The default switch setting is for plug and play.) The an
driver has Plug and Play support and will work in either configuration,
however when using a hard-wired I/O address and IRQ, the driver
configuration and the NIC's switch settings must agree. PCI cards
require no switch settings of any kind and will be automatically probed
All host/device interaction with the Aironet cards is via programmed I/O.
The an driver encapsulates all IP and ARP traffic as 802.11 frames,
though it can receive either 802.11 or 802.3 frames.
These are the modes the an driver can operate in:
BSS mode Also known as infrastructure mode, this is used when
associating with an access point, through which all
traffic passes. This mode is the default.
IBSS mode Also known as IEEE ad-hoc mode or peer-to-peer mode. This
is the standardized method of operating without an access
point. Stations associate with a service set. However,
actual connections between stations are peer-to-peer.
monitor mode In this mode the driver is able to receive packets without
associating with an access point. This disables the
internal receive filter and enables the card to capture
packets from networks which it wouldn't normally have
access to, or to scan for access points.
The an driver can be configured to use hardware Wired Equivalent Privacy
(WEP). It is strongly recommended that WEP not be used as the sole
mechanism to secure wireless communication, due to serious weaknesses in
The an driver can be configured at runtime with ifconfig(8) or on boot
The following hostname.if(5) example configures an0 to join whatever
network is available on boot, using WEP key ``0x1deadbeef1'', channel 11,
obtaining an IP address using DHCP:
dhcp NONE NONE NONE nwkey 0x1deadbeef1 chan 11
Configure an0 for WEP, using hex key ``0x1deadbeef1'':
# ifconfig an0 nwkey 0x1deadbeef1
Return an0 to its default settings:
# ifconfig an0 -bssid -chan media autoselect \
nwid "" -nwkey
Join an existing BSS network, ``my_net'':
# ifconfig an0 192.168.1.1 netmask 0xffffff00 nwid my_net
an%d: failed to allocate %d bytes on NIC The driver was unable to
allocate memory for transmit frames in the NIC's on-board RAM.
an%d: device timeout The Aironet card failed to generate an interrupt to
acknowledge a transmit command.
SEE ALSOarp(4), ifmedia(4), intro(4), isapnp(4), netintro(4), pci(4), pcmcia(4),
The an device driver first appeared in FreeBSD 4.0. OpenBSD support was
added in OpenBSD 2.7. A version of the driver based on the one in NetBSD
was added in OpenBSD 3.9.
The an driver was written by Bill Paul <firstname.lastname@example.org> and ported
to OpenBSD by Michael Shalayeff <email@example.com>. Later the NetBSD
version of the driver by Atsushi Onoe was subsequently ported to OpenBSD
by Jonathan Gray <firstname.lastname@example.org>.
Scanning for access points is not currently supported.
OpenBSD 4.9 September 2, 2009 OpenBSD 4.9