arp man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

ARP(4)			 BSD Kernel Interfaces Manual			ARP(4)

NAME
     arp — Address Resolution Protocol

SYNOPSIS
     #include <netinet/if_ether.h>

DESCRIPTION
     The Address Resolution Protocol (ARP) is a protocol used to dynamically
     map between Internet host addresses and Ethernet addresses.  It is used
     by all the Ethernet interface drivers.  It is not specific to Internet
     protocols or to Ethernet, but this implementation currently supports only
     that combination.

     ARP caches Internet-Ethernet address mappings.  When an interface
     requests a mapping for an address not in the cache, ARP queues the mes‐
     sage which requires the mapping and broadcasts a message on the associ‐
     ated network requesting the address mapping.  If a response is provided,
     the new mapping is cached and any pending message is transmitted.	ARP
     will queue at most one packet while waiting for a response to a mapping
     request; only the most recently ``transmitted'' packet is kept.  If the
     target host does not respond after several requests, the host is consid‐
     ered to be down for a short period (normally 20 seconds), allowing an
     error to be returned to transmission attempts during this interval.  The
     error is EHOSTDOWN for a non-responding destination host, and
     EHOSTUNREACH for a non-responding router.

     The ARP cache is stored in the system routing table as dynamically-cre‐
     ated host routes.	The route to a directly-attached Ethernet network is
     installed as a “cloning” route (one with the RTF_CLONING flag set), caus‐
     ing routes to individual hosts on that network to be created on demand.
     These routes time out periodically (normally 20 minutes after validated;
     entries are not validated when not in use).  An entry for a host which is
     not responding is a “reject” route (one with the RTF_REJECT flag set).

     ARP entries may be added, deleted or changed with the arp(8) utility.
     Manually-added entries may be temporary or permanent, and may be
     “published”, in which case the system will respond to ARP requests for
     that host as if it were the target of the request.

     In the past, ARP was used to negotiate the use of a trailer encapsula‐
     tion.  This is no longer supported.

     ARP watches passively for hosts impersonating the local host (i.e. a host
     which responds to an ARP mapping request for the local host's address).

DIAGNOSTICS
     duplicate IP address %x sent from ethernet address %x:%x:%x:%x:%x:%x.
     ARP has discovered another host on the local network which responds to
     mapping requests for its own Internet address with a different Ethernet
     address, generally indicating that two hosts are attempting to use the
     same Internet address.

SEE ALSO
     inet(4), route(4), arp(8), ifconfig(8), route(8)

     Plummer, D., "RFC 826", An Ethernet Address Resolution Protocol.

     Leffler, S.J.  and Karels, M.J., "RFC 893", Trailer Encapsulations.

BSD				April 18, 1994				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net