ASP(4) OpenBSD Programmer's Manual (HPPA) ASP(4)NAMEasp - core bus controller as present on older HP 9000/700 machines
asp0 at mainbus? irq 28
gsc* at asp?
The supported Core bus controllers are those present on older PA-RISC
workstations, and include:
o Core bus controller
o System Clock
o Interrupt Controller
o DMA Controller
o Real Time Clock Interface
o RAM and EEPROM controllers
The irq level supplied is hardwired to the CPU pin, so changing the value
would not produce any noticeable results (except lost interrupts for the
whole I/O subsystem).
An incomplete list of machines that use the ASP bus controller:
o 705, 710
o 720, 730, 750
SEE ALSOgsc(4), intro(4), io(4)
Hardball I/O Subsystem ERS, Revision 1.1, Hewlett-Packard, 30 September
The asp driver appeared in OpenBSD 2.4.
OpenBSD 4.9 May 31, 2007 OpenBSD 4.9