atf man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

ATF(7)		     BSD Miscellaneous Information Manual		ATF(7)

NAME
     ATF — introduction to the Automated Testing Framework

DESCRIPTION
     IMPORTANT: If you are here because you want to know how to run the tests
     in /usr/tests, you most likely want to read the tests(7) manual page
     instead.

     The Automated Testing Framework (ATF) is a collection of libraries and
     utilities designed to ease unattended application testing in the hands of
     developers and end users of a specific piece of software.

     As regards developers, ATF provides the necessary means to easily create
     test suites composed of multiple test programs, which in turn are a col‐
     lection of test cases.  It also attempts to simplify the debugging of
     problems when these test cases detect an error by providing as much
     information as possible about the failure.

     As regards users, it simplifies the process of running the test suites
     and, in special, encourages end users to run them often: they do not need
     to have source trees around nor any other development tools installed to
     be able to certify that a given piece of software works on their machine
     as advertised.

     If your operating systems distributes ATF, it is possible that it pro‐
     vides an introductory tests(7) manual page.  You are encouraged to read
     it now.

   License
     ATF is distributed under the terms of the TNF License, a 2-clause BSD
     license.  For more details please see:

	   /usr/share/doc/atf/COPYING

   Components
     ATF is a highly modular piece of software.	 It provides a couple of
     libraries to ease the implementation of test programs: one for the C and
     C++ languages and another one for shell scripts.  It also includes multi‐
     ple small utilities that follow the principle of doing a single thing but
     doing it right.  This section outlines which these components are.

     Public utilities:

     atf-check(1)	    Executes a command and checks that its exit code,
			    its standard output and its standard error output
			    match pre-specified expected values.

     atf-config(1)	    Queries static configuration information.

     atf-report(1)	    Converts the output of atf-run to user-friendly
			    and/or machine-parseable reports.

     atf-run(1)		    Automates the execution of a series of test pro‐
			    grams and collects their results in a unified
			    report.

     atf-sh(1)		    Shell interpreter for shell-based test programs.

     Programming interfaces:

     atf-c-api(3)	    C programming interface for test programs.

     atf-c++-api(3)	    C++ programming interface for test programs.

     atf-sh-api(3)	    POSIX shell programming interface for test pro‐
			    grams.

     Other:

     atf-formats(5)	    Description of the machine-parseable data formats
			    used by the tools.

     atf-test-case(4)	    Generic description of test cases, independent of
			    the language they are implemented in.

     atf-test-program(1)    Common interface provided by the test programs
			    written using the ATF libraries.

   Recommended reading order
     For end users wishing to run tests:
     1.	  tests(7) (only if provided by your operating system).
     2.	  atf-test-program(1)
     3.	  atf-run(1)
     4.	  atf-report(1)
     5.	  atf-config(1)

     For developers wanting to write their own tests:
     1.	  Everything recommended to users.
     2.	  atf-test-case(4)
     3.	  atf-c-api(3)
     4.	  atf-c++-api(3)
     5.	  atf-sh-api(3)
     6.	  atf-sh(1)
     7.	  atf-check(1)

     For those interested in ATF internals:
     1.	  Everything recommended to users.
     2.	  Everything recommended to developers.
     3.	  atf-formats(5)

SEE ALSO
     tests(7)

HISTORY
     ATF started as a Google Summer of Code 2007 project mentored by The Net‐
     BSD Foundation.  Its original goal was to provide a testing framework for
     The NetBSD Operating System, but it grew as an independent project
     because the framework itself did not need to be tied to a specific oper‐
     ating system.

     For more details on this subject, please see:

	   /usr/share/doc/atf/NEWS
	   /usr/share/doc/atf/ROADMAP

AUTHORS
     For more details on the people that made ATF possible, please see:

	   /usr/share/doc/atf/AUTHORS

BSD				August 28, 2010				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net