ATRUN(8) BSD System Manager's Manual ATRUN(8)NAMEatrun — run jobs queued for later execution
SYNOPSISatrun [-l load_avg] [-d]
Atrun runs jobs queued by at(1).
Root's crontab(5) file /etc/crontab has to contain the line
*/5 * * * * root /usr/libexec/atrun
so that atrun gets invoked every five minutes.
At every invocation, atrun will start all the jobs in the lowercase
queues whose start time has elapsed. In addition, if the load average
over the last minute was less than the specified limit then a maximum of
one batch job (denoted by the uppercase queues) is started.
Before starting a job, atrun will check the status of its owner's account
with pam(3) and refuse to run the job if the account is unavailable,
e.g., locked out or expired.
Specify a limiting load factor, over which batch jobs should not
be run, instead of the compiled in default of 1.5.
-d Debug; print error messages to standard error instead of using
For atrun to work, you have to start up a cron(8) daemon.
/etc/pam.d/atrun pam.conf(5) configuration file for atrun
/var/at/jobs Directory containing job files
/var/at/spool Directory containing output spool files
SEE ALSOat(1), crontab(1), pam(3), syslog(3), crontab(5), pam.conf(5), cron(8)BUGS
The functionality of atrun should be merged into cron(8).
BSD June 17, 2007 BSD