bcopy man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

BCOPY(9)		 BSD Kernel Developer's Manual		      BCOPY(9)

NAME
     bcopy — copy byte string

SYNOPSIS
     #include <sys/systm.h>

     void
     bcopy(const void *src, void *dst, size_t len);

DESCRIPTION
     The bcopy() interface is obsolete.	 Do not add new code using it.	It
     will soon be purged.  Use memcpy(9) instead.  (The bcopy() function is
     now a macro for memcpy(9).)

     The bcopy() function copies len bytes from string src to string dst.

     Unlike bcopy(3) the two strings must not overlap!	In the traditional BSD
     kernel, overlapping copies were handled by the now-purged ovbcopy() func‐
     tion.  If you need to copy overlapping data, see memmove(9).

     If len is zero, no bytes are copied.

SEE ALSO
     bcopy(3), memcpy(9), memmove(9)

BSD				 July 7, 2001				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net