bintime_addx man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

BINTIME_ADD(9)		 BSD Kernel Developer's Manual		BINTIME_ADD(9)

NAME
     bintime_add — operations on “bintime”

SYNOPSIS
     #include <sys/time.h>

     vid
     bintime_add(struct bintime *bt, const struct bintime *bt2);

     void
     bintime_addx(struct bintime *bt, uint64_t x);

     void
     bintime_sub(struct bintime *bt, const struct bintime *bt2);

     void
     bintime2timespec(const struct bintime *bt, struct timespec *ts);

     void
     timespec2bintime(const struct timespec *ts, struct bintime *bt);

     void
     bintime2timeval(const struct bintime *bt, struct timeval *tv);

     void
     timeval2bintime(const struct timeval *tv, struct bintime *bt);

DESCRIPTION
     These functions are provided for convenience as part of the machine-inde‐
     pendent timecounter(9) framework.	All of them operate with the bintime
     structure.

     The function bintime_add() adds the time information stored in bt2 to bt.
     Conversely, bintime_sub() subtracts bt2 from bt.  The bintime_addx()
     function stores the fraction of a second x to bt.

     Like the function names bespeak, bintime2timespec() converts the bintime
     structure to struct timespec and timespec2bintime() does the opposite.
     The functions bintime2timeval() and timeval2bintime() operate with struct
     timeval instead.  The result is stored to the right-hand side.

SEE ALSO
     timeradd(3), timeval(3), bintime(9), timecounter(9)

BSD				 June 8, 2010				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net