binuptime man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

MICROUPTIME(9)		 BSD Kernel Developer's Manual		MICROUPTIME(9)

NAME
     binuptime, getbinuptime, microuptime, getmicrouptime, nanouptime,
     getnanouptime — get the time elapsed since boot

SYNOPSIS
     #include <sys/time.h>

     void
     binuptime(struct bintime *bt);

     void
     getbinuptime(struct bintime *bt);

     void
     microuptime(struct timeval *tv);

     void
     getmicrouptime(struct timeval *tv);

     void
     nanouptime(struct timespec *ts);

     void
     getnanouptime(struct timespec *tsp);

DESCRIPTION
     The binuptime() and getbinuptime() functions store the time elapsed since
     boot as a struct bintime at the address specified by bt.  The
     microuptime() and getmicrouptime() functions perform the same utility,
     but record the elapsed time as a struct timeval instead.  Similarly the
     nanouptime() and getnanouptime() functions store the elapsed time as a
     struct timespec.

     The binuptime(), microuptime(), and nanouptime() functions always query
     the timecounter to return the current time as precisely as possible.
     Whereas getbinuptime(), getmicrouptime(), and getnanouptime() functions
     are abstractions which return a less precise, but faster to obtain, time.

     The intent of the getbinuptime(), getmicrouptime(), and getnanouptime()
     functions is to enforce the user's preference for timer accuracy versus
     execution time.

SEE ALSO
     bintime(9), getbintime(9), getmicrotime(9), getnanotime(9), microtime(9),
     nanotime(9), tvtohz(9)

AUTHORS
     This manual page was written by Kelly Yancey ⟨kbyanc@posi.net⟩.

BSD			      September 16, 2004			   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net