BOOT_ZAURUS(8) OpenBSD System Manager's Manual (Zaurus) BOOT_ZAURUS(8)NAMEboot_zaurus - zaurus system bootstrapping procedures
When powered on, or if the system is rebooted via reboot(8) or
shutdown(8), the processor begins executing code at physical address 0.
The early startup code is preinstalled by the manufacturer, and will load
a minimal UNIX-like operating system from internal flash memory (our
primary bootstrap loader, for now).
Boot process options
On most systems, booting OpenBSD from the primary bootstrap loader will
eventually load the OpenBSD-specific zaurus bootstrapping code. This
versatile program is described in a separate document, boot(8).
Abnormal system termination
In case of system crashes, the kernel will usually enter the kernel
debugger, ddb(4), unless it is not present in the kernel, or it is
disabled via the ddb.panic sysctl. Upon leaving ddb, or if ddb was not
entered, the kernel will halt the system if it was still in device
configuration phase, or attempt a dump to the configured dump device, if
possible. The crash dump will then be recovered by savecore(8) during
the next multi-user boot cycle. It is also possible to force other
behaviours from ddb.
/bsd default system kernel
/bsd.rd standalone installation kernel, suitable for
/usr/mdec/zboot system bootstrap
/usr/mdec/zbsdmod.o kernel module for the primary bootstrap loader that
must be loaded before the system bootstrap
SEE ALSOddb(4), boot(8), halt(8), init(8), reboot(8), savecore(8), shutdown(8)OpenBSD 4.9 May 31, 2007 OpenBSD 4.9