BOS(8) OpenBSD System Manager's Manual BOS(8)NAMEbos - is the client part of the Basic Overseer Daemon that manages AFS
SYNOPSISbos [addhost | addkey | adduser | create] [args]
bos [delete | exec | getdate | getlog] [args]
bos [getrestart | install | listhosts | listkeys] [args]
bos [listusers | prune | removehost | removekey] [args]
bos [removeuser | restart | salvage | setauth] [args]
bos [setcellname | setrestart | shutdown | start] [args]
bos [stop | uninstall] [args]
The bos utility is the client part of the Basic overseer daemon that
manage AFS server processes.
Most bos commands accept the following general arguments:
[-cell cellname] Specifies which AFS cell to use, if the default
cell is not to be used.
[-noauth] Specifies that bos should not try to authenticate the
connection to the server. This may be useful with shell scripts,
or if there is a problem with the AFS cell. Note that the server
will reject many commands if -noauth is specified.
[-localauth] Create a ticket using the AFS server key, that is, you
don't need a token. This will generally only work on AFS servers,
and is very useful for performing automatic tasks.
bos has several subcommands:
addhost -server server -host host [-cell cellname] [-noauth] [-localauth]
Add a new host to the CellServDB on the server. This makes the
database server consider host as a peer and will use when they
synchronize their databases (the database servers) need to be
addkey -server server [-key key] [-kvno keyversionnumber] [-cell
cellname] [-noauth] [-localauth]
Add a new afs-key to the KeyFile. Add the ticket specified in key
with keyversionnumber to the server.
adduser -server server -user user [-cell cellname] [-noauth] [-localauth]
Add a new user the SuperUser file on the fileserver server, thus
giving that user the right to manage volumes and bosserver.
create -server server -instance serverprocessname -type servertype -cmd
command [-notifier program] [-cell cellname] [-noauth] [-localauth]
Create a new service instance at the server of type. The instance
will depending on type run the command command.
delete -server server -instance instance [-cell cellname] [-noauth]
Delete the instance from the server.
-server server -cmd command [-cell cellname] [-noauth] [-localauth]
Execute command on the server server.
getdate -server server -files checkfiles [-dir dir] [-cell cellname]
Get dates for checkfiles in server-root directory (that can be
specified with dir if that is needed) on server.
getlog -server server -file logfile [-cell cellname] [-noauth]
List the content of the logfile that resides on the server.
getrestart -server server [-dir dest] [-cell cellname] [-noauth]
Get the restart time from server.
SEE ALSOfs(1), pts(1), afsd(8), vos(8)BUGS
Quite a lot of commands are not implemented yet.
The Arla Project April 1, 2003 The Arla Project