BUS_CHILD_PRESENT(9) BSD Kernel Developer's Manual BUS_CHILD_PRESENT(9)NAMEbus_child_present — ask the bus driver to see if this device is still
The bus_child_present() function requests that the parent device driver
of dev check to see if the hardware represented by dev is still physi‐
cally accessible at this time. While the notion of accessible varies
from bus to bus, generally hardware that is not accessible cannot be
accessed via the bus_space*() methods that would otherwise be used to
access the device.
This does not ask the question “does this device have children?” which
can better be answered by device_get_children(9).
A zero return value indicates that the device is not present in the sys‐
tem. A non-zero return value indicates that the device is present in the
system, or that the state of the device cannot be determined.
This is some example code. It only calls stop when the dc(4) device is
sc = device_get_softc(dev);
SEE ALSOdevice(9), driver(9)AUTHORS
This manual page was written by Warner Losh ⟨imp@FreeBSD.org⟩.
BSD March 27, 2003 BSD