bus_generic_new_pass man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

BUS_GENERIC_NEW_PASS(9)	 BSD Kernel Developer's Manual BUS_GENERIC_NEW_PASS(9)

NAME
     bus_generic_new_pass — generic implementation of BUS_NEW_PASS for bus
     devices

SYNOPSIS
     #include <sys/param.h>
     #include <sys/bus.h>

     void
     bus_generic_new_pass(device_t dev);

DESCRIPTION
     This function provides an implementation of the BUS_NEW_PASS(9) method
     which can be used by bus drivers.	It first invokes the
     DEVICE_IDENTIFY(9) method for any drivers whose pass level is equal to
     the new pass level.  Then, for each attached child device it calls
     BUS_NEW_PASS(9) to rescan child busses, and for each unattached child
     device it calls device_probe_and_attach(9).

SEE ALSO
     BUS_NEW_PASS(9), bus_set_pass(9), device(9), DEVICE_IDENTIFY(9)

BSD				 June 8, 2009				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net