cd man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

CD(4)			 BSD Kernel Interfaces Manual			 CD(4)

NAME
     cd — SCSI and ATAPI CD-ROM driver

SYNOPSIS
     cd* at scsibus? target ? lun ?
     cd1 at scsibus0 target 4 lun 0
     cd* at atapibus? drive ? flags 0x0000

DESCRIPTION
     The cd driver provides support for a Small Computer Systems Interface
     (SCSI) bus and Advanced Technology Attachment Packet Interface (ATAPI)
     Compact Disc-Read Only Memory (CD-ROM) drive.  In an attempt to look like
     a regular disk, the cd driver synthesizes a partition table, with one
     partition covering the entire CD-ROM.  It is possible to modify this par‐
     tition table using disklabel(8), but it will only last until the CD-ROM
     is unmounted.  In general the interfaces are similar to those described
     by wd(4) and sd(4).

     As the SCSI adapter is probed during boot, the SCSI bus is scanned for
     devices.  Any devices found which answer as `Read-only' type devices will
     be `attached' to the cd driver.

     For the use of flags with ATAPI devices, see wd(4).

     The system utility disklabel(8) may be used to read the synthesized disk
     label structure, which will contain correct figures for the size of the
     CD-ROM should that information be required.

KERNEL CONFIGURATION
     Any number of CD-ROM devices may be attached to the system regardless of
     system configuration as all resources are dynamically allocated.

IOCTLS
     The following ioctl(2) calls which apply to SCSI CD-ROM drives are
     defined in the header files <sys/cdio.h> and <sys/disklabel.h>.

     DIOCGDINFO

     DIOCSDINFO		  (struct disklabel) Read or write the in-core copy of
			  the disklabel for the drive.	The disklabel is ini‐
			  tialized with information read from the SCSI inquiry
			  commands, and should be the same as the information
			  printed at boot.  This structure is defined in
			  disklabel(5).

     CDIOCPLAYTRACKS	  (struct ioc_play_track) Start audio playback given a
			  track address and length.  The structure is defined
			  as follows:

				struct ioc_play_track
				{
					u_char	start_track;
					u_char	start_index;
					u_char	end_track;
					u_char	end_index;
				};

     CDIOCPLAYBLOCKS	  (struct ioc_play_blocks) Start audio playback given
			  a block address and length.  The structure is
			  defined as follows:

				struct ioc_play_blocks
				{
					int	blk;
					int	len;
				};

     CDIOCPLAYMSF	  (struct ioc_play_msf) Start audio playback given a
			  `minutes-seconds-frames' address and length.	The
			  structure is defined as follows:

				struct ioc_play_msf
				{
					u_char	start_m;
					u_char	start_s;
					u_char	start_f;
					u_char	end_m;
					u_char	end_s;
					u_char	end_f;
				};

     CDIOCREADSUBCHANNEL  (struct ioc_read_subchannel) Read information from
			  the subchannel at the location specified by this
			  structure:

				struct ioc_read_subchannel {
					u_char address_format;
				#define CD_LBA_FORMAT	1
				#define CD_MSF_FORMAT	2
					u_char data_format;
				#define CD_SUBQ_DATA		0
				#define CD_CURRENT_POSITION	1
				#define CD_MEDIA_CATALOG	2
				#define CD_TRACK_INFO		3
					u_char track;
					int	data_len;
					struct	cd_sub_channel_info *data;
				};

     CDIOREADTOCHEADER	  (struct ioc_toc_header) Return summary information
			  about the table of contents for the mounted CD-ROM.
			  The information is returned into the following
			  structure:

				struct ioc_toc_header {
					u_short len;
					u_char	starting_track;
					u_char	ending_track;
				};

     CDIOREADTOCENTRYS	  (struct ioc_read_toc_entry) Return information from
			  the table of contents entries mentioned.  (Yes, this
			  command name is misspelled).	The argument structure
			  is defined as follows:

				struct ioc_read_toc_entry {
					u_char	address_format;
					u_char	starting_track;
					u_short data_len;
					struct	cd_toc_entry *data;
				};
			  The requested data is written into an area of size
			  data_len and pointed to by data.

     CDIOCSETPATCH	  (struct ioc_patch) Attach various audio channels to
			  various output channels.  The argument structure is
			  defined thusly:

				struct ioc_patch {
					u_char	patch[4];
					/* one for each channel */
				};

     CDIOCGETVOL

     CDIOCSETVOL	  (struct ioc_vol) Get (set) information about the
			  volume settings of the output channels.  The argu‐
			  ment structure is as follows:

				struct	ioc_vol
				{
					u_char	vol[4];
					/* one for each channel */
				};

     CDIOCSETMONO	  Patch all output channels to all source channels.

     CDIOCSETSTEREO	  Patch left source channel to the left output channel
			  and the right source channel to the right output
			  channel.

     CDIOCSETMUTE	  Mute output without changing the volume settings.

     CDIOCSETLEFT

     CDIOCSETRIGHT	  Attach both output channels to the left (right)
			  source channel.

     CDIOCSETDEBUG

     CDIOCCLRDEBUG	  Turn on (off) debugging for the appropriate device.

     CDIOCPAUSE

     CDIOCRESUME	  Pause (resume) audio play, without resetting the
			  location of the read-head.

     CDIOCRESET		  Reset the drive.

     CDIOCSTART

     CDIOCSTOP		  Tell the drive to spin-up (-down) the CD-ROM.

     CDIOCALLOW

     CDIOCPREVENT	  Tell the drive to allow (prevent) manual ejection of
			  the CD-ROM disc.  Not all drives support this fea‐
			  ture.

     CDIOCEJECT		  Eject the CD-ROM.

     CDIOCLOADUNLOAD	  Cause the ATAPI changer to load or unload discs.

     CDIOCCLOSE		  Tell the drive to close its door and load the media.
			  Not all drives support this feature.

     In addition the general scsi(4) ioctls may be used with the cd driver, if
     used against the `whole disk' partition (i.e.  /dev/rcd0d for the bebox
     and i386 port, /dev/rcd0c for all other ports).

NOTES
     When a CD-ROM is changed in a drive controlled by the cd driver, then the
     act of changing the media will invalidate the disklabel and information
     held within the kernel.  To stop corruption, all accesses to the device
     will be discarded until there are no more open file descriptors referenc‐
     ing the device.  During this period, all new open attempts will be
     rejected.	When no more open file descriptors reference the device, the
     first next open will load a new set of parameters (including disklabel)
     for the drive.

     The audio code in the cd driver only support SCSI-2 standard audio com‐
     mands.  Because many CD-ROM manufacturers have not followed the standard,
     there are many CD-ROM drives for which audio will not work.  Some work is
     planned to support some of the more common `broken' CD-ROM drives; how‐
     ever, this is not yet under way.

FILES
     /dev/cd[0-9][a-h]	 block mode CD-ROM devices
     /dev/rcd[0-9][a-h]	 raw mode CD-ROM devices

DIAGNOSTICS
     None.

SEE ALSO
     intro(4), scsi(4), sd(4), wd(4), disklabel(5), disklabel(8)

HISTORY
     The cd driver appeared in 386BSD 0.1.

BUGS
     The names of the structures used for the third argument to ioctl() were
     poorly chosen, and a number of spelling errors have survived in the names
     of the ioctl() commands.

BSD			       January 16, 1996				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net