CHKGRP(8) BSD System Manager's Manual CHKGRP(8)NAMEchkgrp — check the syntax of the group file
The chkgrp utility scans the given file or, failing that, the system-wide
group file for errors. Specifically, it checks that every non-blank,
non-comment entry is composed of four colon-separated fields, that none
of them contains whitespace, and that the third field (the group ID) is
numeric. It will also check for invalid characters in the group names
and group members.
/etc/group group database file
The chkgrp utility returns EX_DATAERR if errors were found in the group
file, and EX_OK otherwise.
For each error found, chkgrp will print an error message containing the
name of the file being scanned and the line number on which the error was
SEE ALSOgetgrent(3), group(5)HISTORY
The chkgrp utility appeared in FreeBSD 3.0.
The chkgrp utility and this manual page were written by Dag-Erling
Smørgrav ⟨des@FreeBSD.org⟩. Further functionality was added by Liam J.
Should check the range of the group ID.
BSD May 26, 2005 BSD