CORETEMP(4) BSD Kernel Interfaces Manual CORETEMP(4)NAMEcoretemp — device driver for Intel Core on-die digital thermal sensor
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The coretemp driver provides support for the on-die digital thermal sen‐
sor present in Intel Core and newer CPUs.
The coretemp driver reports each core's temperature through a sysctl node
in the corresponding CPU device's sysctl tree, named
The coretemp driver first appeared in FreeBSD 7.0.
The coretemp driver was written by Rui Paulo ⟨rpaulo@FreeBSD.org⟩ as part
of a Google Summer of Code project. This manual page was written by
Dag-Erling Smørgrav ⟨des@FreeBSD.org⟩.
BSD August 23, 2007 BSD