cpu_idle man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

CPU_IDLE(9)		 BSD Kernel Developer's Manual		   CPU_IDLE(9)

NAME
     cpu_idle — machine-dependent processor idling interface

SYNOPSIS
     #include <sys/cpu.h>

     void
     cpu_idle(void);

DESCRIPTION
     cpu_idle() is called by machine-independent code when the processor has
     nothing to do.  It can be used to conserve the processor power, for exam‐
     ple.

     cpu_idle() returns immediately if cpu_need_resched() has been called for
     the processor after the last call of cpu_idle() or cpu_did_resched() on
     the processor.  cpu_idle() returns as soon as possible when
     cpu_need_resched() is called for the processor.  Otherwise, it returns
     whenever it likes.

     cpu_idle() is called at IPL_NONE, without any locks held.

EXAMPLES
     The simplest (and, in some cases, the best) implementation of cpu_idle()
     is the following.

	     void
	     cpu_idle(void)
	     {
		     /* nothing */
	     }

SEE ALSO
     cpu_need_resched(9), cpu_switchto(9), intro(9), spl(9)

BSD				April 20, 2007				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net