cpu_rootconf man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

CPU_ROOTCONF(9)		 BSD Kernel Developer's Manual	       CPU_ROOTCONF(9)

NAME
     cpu_rootconf, rootconf, setroot — root file system setup

SYNOPSIS
     #include <sys/types.h>
     #include <sys/systm.h>

     void
     cpu_rootconf(void);

     void
     rootconf(void);

     void
     setroot(device_t bootdv, int bootpartition);

DESCRIPTION
     The cpu_rootconf() is a machine-dependent interface invoked during system
     bootstrap to determine the root file system device and initialize
     machine-dependent file system state.  cpu_rootconf() provides the global
     variables booted_device, booted_partition, booted_startblk and
     booted_nblks and invokes the machine-independent function rootconf which
     rootconf then calls the function setroot to record the boot/root device
     and the boot partition information for use in machine-independent code.

     For disk boot, if booted_nblks is not 0, then booted_startblk and
     booted_nblks are supposed to specify a disk wedge that is used as the
     root device.  Otherwise the booted_partition is used.

SEE ALSO
     boot(8), boothowto(9), dk(4)

BSD				April 13, 2010				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net