crashutil(1M)crashutil(1M)NAMEcrashutil - manipulate crash dump data
version] source [destination]
copies and preserves crash dump data, and performs format conversions
on it. Common uses of include:
· Copying portions of a dump that still reside on a raw dump device
into a crash dump directory.
· Converting between different formats of crash dumps.
· Copying crash dumps from one directory, or medium, to another.
will write to its destination the crash dump it reads from its source.
The crash dump format used to write the destination is specified with
if is not specified, the destination will have the same format as the
source. If no destination is specified, source is used; the format
conversion will be done in place in the source, without copying. When
completes successfully, the entire contents of the crash dump will
exist at destination; any portions that had still been on raw dump
devices will have been copied to destination.
There are three known dump formats:
(Version 0) This format, used up through HP-UX 10.01, consists of a
single file containing the physical memory image, with a
1-to-1 correspondence between file offset and memory
address. Normally there is an associated file containing
the kernel image. sources or destinations of this type
must be specified as two pathnames to plain files, sepa‐
rated by whitespace; the first is the core image file and
the second is the kernel image file.
(Version 1) This format, used in HP-UX 10.10, 10.20, and 10.30, con‐
sists of a directory containing an file, the kernel file,
and numerous files, which contain portions of the physi‐
cal memory image. sources or destinations of this type
should be specified as the pathname to a core directory.
(Version 2) This format, used in HP-UX 11.00 and later, consists of a
directory containing an file, the kernel and all dynami‐
cally loaded kernel module files, and numerous files,
each of which contain portions of the physical memory
image and metadata describing which memory pages were
dumped and which were not. sources or destinations of
this type should be specified as the pathname to a crash
(Version 3) This format is used in HP-UX Release 11i Version 1.0 and
later. It is very similar in structure to the format in
that it consists of a directory containing an file, the
kernel and all dynamically loaded kernel module files,
and numerous files, each of which contain portions of the
physical memory image and metadata describing which mem‐
ory pages were dumped and which were not. In addition to
the primary file, there are auxiliary index files, that
contain metadata describing the image files containing
the memory pages. This format will be used when the dump
is compressed. See crashconf(1M).
Other formats, for example tape archival formats, may be added in the
When the source and destination are different types of files — for
example, when source is a directory and destination is a pair of plain
files — both must be specified.
(Quiet) Disables the printing of progress messages.
Warning and error messages are still printed.
Specifies the version of the destination format.
Allowed values are 0, 1, 2 or 3. Also allowed is the key‐
word which specifies that the destination format should be
the same as the current source format. is the default if
is not specified. If the destination format is then the
source format should also be Conversion to from older for‐
mats is not supported.
Upon exit, returns the following values:
0 The operation was successful.
1 The operation failed, and an appropriate error message was
An HP-UX 11.00 crash dump was saved by savecrash(1M) to The flag was
specified to savecrash, specifying that only those portions of the dump
which were endangered by swap activity should be saved; the rest are
still resident in the raw dump devices. To save the remainder of the
dump into the crash dump directory, use:
If preferred, the completed crash dump directory could be in a differ‐
ent location — perhaps on another machine via NFS:
To debug this crash dump using tools which do not understand the most
current crash dump format, convert it to the older core directory for‐
or the even older "core file and kernel" format:
was developed by HP.
SEE ALSOsavecrash(1M), crashconf(1M).