DAEMON(8) BSD System Manager's Manual DAEMON(8)NAMEdaemon — run detached from the controlling terminal
SYNOPSISdaemon [-cf] [-p pidfile] [-u user] command arguments ...
The daemon utility detaches itself from the controlling terminal and exe‐
cutes the program specified by its arguments. Privileges may be lowered
to the specified user.
The options are as follows:
-c Change the current working directory to the root (“/”).
-f Redirect standard input, standard output and standard error to
Write the ID of the created process into the file using the
pidfile(3) functionality. Note, that the file will be created
shortly before the process is actually executed, and will remain
after the process exits (although it will be removed if the exe‐
Run the program with the rights of user specified, requires priv‐
The daemon utility exits 1 if an error is returned by the daemon(3)
library routine, 2 if the pidfile is requested, but cannot be opened, 3
if process is already running (pidfile exists and is locked), otherwise
If the command cannot be executed, an error message is displayed on stan‐
dard error unless the -f flag is specified.
SEE ALSOsetregid(2), setreuid(2), daemon(3), exec(3), pidfile(3), termios(4),
The daemon utility first appeared in FreeBSD 4.7.
BSD March 19, 2007 BSD