ddi_fm_acc_err_clear man page on Solaris

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
Solaris logo
[printable version]

ddi_fm_acc_err_clear(9F) Kernel Functions for Drivers ddi_fm_acc_err_clear(9F)

NAME
       ddi_fm_acc_err_clear, ddi_fm_dma_err_clear - clear the error status for
       an access or DMA handle

SYNOPSIS
       #include <sys/ndifma.h>

       void ddi_fm_acc_err_clear(ddi_acc_handle_t acc_handle,
	   int version);

       void ddi_fm_dma_err_clear(ddi_dma_handle_t dma_handle,
	   int version);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

PARAMETERS
       acc_handle    Data access handle	 obtained  from	 a  previous  call  to
		     ddi_regs_map_setup(9F),  ddi_dma_mem_alloc(9F),  or  to a
		     similar function.

       dma_handle    DMA   handle   obtained   from   a	  previous   call   to
		     ddi_dma_mem_alloc(9F) or one of its derivatives.

       version	     Version number of ddi_fm_error_t.

DESCRIPTION
       The  ddi_fm_dma_err_clear()  and ddi_fm_acc_err_clear() functions clear
       the error status of a DMA or access handle respectively.

       Once cleared, the driver is again able to access the  mapped  registers
       or memory using programmed I/O through the handle.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Committed			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       attributes(5),	   ddi_dma_mem_alloc(9F),      ddi_fm_acc_err_get(9F),
       ddi_fm_dma_err_get(9F), ddi_regs_map_setup(9F)

SunOS 5.10			  10 May 2007	      ddi_fm_acc_err_clear(9F)
[top]

List of man pages available for Solaris

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net