ddi_fm_service_impact man page on SunOS

Man page or keyword search:  
man Server   20652 pages
apropos Keyword Search (all sections)
Output format
SunOS logo
[printable version]

ddi_fm_service_impact(9F)Kernel Functions for Driversddi_fm_service_impact(9F)

NAME
       ddi_fm_service_impact - report the impact of an error

SYNOPSIS
       #include <sys/ddifm.h>

       void ddi_fm_service_impact(dev_info_t *dip, int *impact);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

PARAMETERS
       dip	 Pointer to the dev_info structure

       impact	 Impact of error

DESCRIPTION
       The  following  service	impact	values	are  accepted  by  ddi_fm_ser‐
       vice_impact():

       DDI_SERVICE_LOST		 The  service  provided	 by  the   device   is
				 unavailable  due to an error. The operational
				 state	of  the	 device	 will  transition   to
				 DEVI_DEVICE_DOWN.

       DDI_SERVICE_DEGRADED	 The  driver  is unable to provide normal ser‐
				 vice,	but  it	 can  provide  a  partial   or
				 degraded  level  of service. The driver might
				 have to make repeated attempts to perform  an
				 operation  before  it	succeeds, or it may be
				 running at less than its configured speed.  A
				 driver may use this value to indicate that an
				 alternative device should be used  if	avail‐
				 able,	but  that it can continue operation if
				 no alternative exists. The operational	 state
				 of    the    device	will   transition   to
				 DEVI_DEVICE_DEGRADED.

       DDI_SERVICE_RESTORED	 The service provided by the device  has  been
				 restored. The operational state of the device
				 will transition to  its  pre-error  condition
				 state	     and      DEVI_DEVICE_DOWN	    or
				 DEVI_DEVICE_DEGRADED is removed.

       DDI_SERVICE_UNAFFECTED	 The service provided by the device was	 unaf‐
				 fected by the error.

CONTEXT
       The  ddi_fm_service_impact()  function can be called from user, kernel,
       or high-level interrupt context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌─────────────────────────────┬─────────────────────────────┐
       │      ATTRIBUTE TYPE	     │	    ATTRIBUTE VALUE	   │
       ├─────────────────────────────┼─────────────────────────────┤
       │Interface Stability	     │Committed			   │
       └─────────────────────────────┴─────────────────────────────┘

SEE ALSO
       fmd(1M), attributes(5), ddi_fm_ereport_post(9F), pci_ereport_post(9F)

SunOS 5.10			  14 May 2007	     ddi_fm_service_impact(9F)
[top]

List of man pages available for SunOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net