delay man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

DELAY(9)		 BSD Kernel Developer's Manual		      DELAY(9)

NAME
     delay, DELAY — microsecond delay

SYNOPSIS
     #include <machine/param.h>

     void
     delay(unsigned int us);

     void
     DELAY(unsigned int us);

DESCRIPTION
     Wait approximately us microseconds.

     The delay is implemented as a machine loop, preventing events other than
     interrupt handlers for unmasked interrupts to run.	 DELAY() is reentrant
     (doesn't modify any global kernel or machine state) and is safe to use in
     interrupt or process context.

     For long delays, condition variables should be considered, however they
     can only be used from process context and their resolution is limited by
     the system clock frequency.

SEE ALSO
     condvar(9), hz(9), kpause(9)

BSD				 July 20, 2011				   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net