DEVCLASS_GET_DEVICES(9) BSD Kernel Developer's Manual DEVCLASS_GET_DEVICES(9)NAMEdevclass_get_devices — get a list of devices in a devclass
devclass_get_devices(devclass_t dc, device_t **devlistp, int *devcountp);
Retrieve a list of all device instances currently in the devclass and
return the list in *devlistp and the count in *devcountp. The memory
allocated for the list should be freed using free(*devlistp, M_TEMP),
even if *devcountp is 0.
Zero is returned on success, otherwise an appropriate error is returned.
SEE ALSOdevclass(9), device(9)AUTHORS
This manual page was written by Doug Rabson.
BSD May 19, 2005 BSD