DEVCLASS_GET_DRIVERS(9) BSD Kernel Developer's Manual DEVCLASS_GET_DRIVERS(9)NAMEdevclass_get_drivers — get a list of drivers in a devclass
devclass_get_drivers(devclass_t dc, driver_t ***listp, int *countp);
Retrieve a list of pointers to all driver instances currently in the dev‐
class and return the list in *listp and the number of drivers in the list
in *countp. The memory allocated for the list should be freed using
free(*listp, M_TEMP), even if *countp is 0.
Zero is returned on success, otherwise an appropriate error is returned.
SEE ALSOdevclass(9), device(9)AUTHORS
This manual page was written by Nate Lawson.
BSD May 19, 2005 BSD